分类:Eclipse

Eclipse

在Eclipse RCP中显示视图时传递参数

我正在创建eclipse RCP应用程序,并且在显示视图时我遇到了传递参数。 作为第一种方法,我尝试在View2中的View2中设置一个静态变量,并打开该视图(如下所示)。有用。 IWorkbenchPage activePage = PlatformUI.getWorkbench()。getActiveWorkbenchWindow()。getActivePage(); Strin

IT屋 2017/8/1 22:46:29 喜欢

Eclipse

强制重新评估命令启用

< handler class =“org .acme.PrintHandler“ commandId =”org.eclipse.ui.file.print“> < activeWhen> < with variable =“activePart”> < test property =“org.acme.printable”/> < / with> < / activeWhen>

IT屋 2017/8/1 22:46:16 喜欢

Eclipse

关于eclipse的问题扩展了工具构建器编程

我想实现一个eclipse插件来添加一个shell脚本作为项目的外部工具构建器。按下插件菜单后,eclipse配置文件.project将添加如下。而另一个配置文件.externalToolBuilders / lstest [Builder]将会生成.lawn将生成。 < buildCommand> < name> org.eclipse.ui.externaltools.External

IT屋 2017/8/1 22:46:03 喜欢

Eclipse

以编程方式访问Eclipse的调用层次结构

我需要以编程方式生成一个调用图形作为Eclipse插件的一部分。我知道Eclipse具有可用的内置Open Call Hierarchy功能,但是我未能找到一种方法来访问它作为插件开发的一部分。有没有人知道如何使用Eclipse的调用层次结构或其他类似的工具? 谢谢 解决方案 您可以在同一个软件包中使用org.eclipse.jdt.internal.corext.callhiera

IT屋 2017/8/1 22:45:48 喜欢

Eclipse

将搜索栏构建到Eclipse View插件中

我正在寻找一些关于如何在现有视图eclipse插件之上构建搜索栏的想法/资源。我想要类似于eclipse中任务列表视图的内容: http://help.targetprocess.com/images/integration_api/eclipse3.png?1337868355 视图我想建立这个只是一个简单的对象列表,基本上就像Eclipse的简单视图教程PDE提供的。没什么复杂的

IT屋 2017/8/1 22:45:35 喜欢

Eclipse

如何创建Eclipse GWT Designer Project,有什么不对?

在下载最新的Eclipse(Luna 4.4.1)之后,我安装了GWT / GWT设计器插件。 我的结论是我缺少WindowsBuilderPro,所以我通过Eclipse帮助 - >安装新软件安装它。 现在我要创建一个新的GTW Designer项目,并获得以下选择,我认为是错误的: 教程,也许更老,显示以下项目选择: 我的安装是否搞砸了?我扭转了安装顺序,没有任何改变。

IT屋 2017/8/1 22:45:21 喜欢

Eclipse

使用我的本地p2存储库与必要的jar文件时项目依赖错误

我已经创建了一个eclipse插件,我需要将eclipse插件项目转换为maven,以便在Tycho.when的帮助下将其转换为maven,当我尝试执行eclipse应用程序时,它可以正常工作。但是当我 [INFO]扫描项目... [INFO]无法完成请求。生成细节。 [INFO]无法完成请求。生成细节。 [INFO] {osgi.ws = gtk,osgi.os = linu

IT屋 2017/8/1 22:45:08 喜欢

Eclipse

如何在资源上删除以前添加的装饰器?

这里有人知道如何删除资源上的特定装饰器?我将 org.eclipse.ui.decorators 扩展到我的项目,并创建了一个实现 ILightweightLabelDecorator 的类。在装饰器类中,我测试了条目是否是项目,并在调用 decorator.addOverlay()之前进行其他测试。我没有实现其他功能,例如 removeListener , isLabelProperty , d

IT屋 2017/8/1 22:44:54 喜欢

Eclipse

使用eclipse运行XSLT时出错

当我使用eclipse xsl开发工具来运行xsl转换时,它会报告以下错误。但是使用萨克森没有问题。如果一些专家可以提供可能的解决方案,SIt将不胜感激。 12:44:14,714 INFO [main] Main - javax.xml主要 - java.endorsed.dirs = / usr / lib / jvm / java-1.6.0-openjdk-1.6.0.0.x

IT屋 2017/8/1 22:44:41 喜欢

Eclipse

ADT不安装在Eclipse Kepler上

我已经下载了Eclipse Kepler,现在试图安装Android ADT。我正在面对下面的问题。 无法找到一个或多个所需项目,因此无法完成安装。 正在安装的软件:Android开发工具22.6.3.v201404151837-1123206(com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)

IT屋 2017/8/1 22:44:28 喜欢