Maven-从x管理的版本,是否因重复而被省略? [英] Maven - version managed from x, omitted for duplicate?

查看:81
本文介绍了Maven-从x管理的版本,是否因重复而被省略?的处理方法,对大家解决问题具有一定的参考价值,需要的朋友们下面随着小编来一起学习吧!

问题描述

我很难理解Maven依赖关系树中当它声明从x管理的版本时会发生什么;如果是重复的,则省略。

例如,假设我在server-a的依赖项管理部分中定义了enterprise-data-2.4

我在server-a的依赖关系树中获取了一个依赖项server-b的以下内容。enterprise-data-2.4

[INFO] +- hello.world.welcome.to:server-b:jar:3.1-SNAPSHOT:runtime
[INFO] |  +- (hello.world.where.am: enterprise-data:jar:2.4:runtime - version managed from 3.0; omitted for duplicate)
假设server-b是唯一拉入的JARenterprise-data-2.4,我的理解是server-a总是在这里拉入enterprise-data-2.4。这样做正确吗?

但是,server-b中代码依赖于enterprise-data-3.0server-b的编译时依赖于enterprise-data-3.0

现在,我有一个测试项目,比如说test-b,它测试server-a项目中存在的server-bJAR,并且对enterprise-data-3.0具有测试依赖关系。这些测试直接命中server-a上的代码。

当我在test-b中运行我的测试时,我在尝试访问enterprise-data-3.0中存在的功能时应该收到错误,因为它不是由server-a引入的,还是会因为对enterprise-data-3.0存在测试依赖关系而通过?它当前已通过,但我不确定测试依赖项是否足够。

请帮我理解一下。

编辑:我正在使用maven-3

谢谢。

推荐答案

例如,假设我在服务器a的依赖项管理部分中定义了Enterprise-data-2.4

然后你总是得到2.4,即使只有取决于1.8的罐子也是如此。依赖项管理优先于依赖项中介。

假设服务器-b是唯一拉入企业数据-2.4的JAR,我的理解是服务器-a将始终在这里拉入企业数据-2.4。这样做正确吗?

假设您没有依赖项管理,则是。如果存在依赖于不同版本的多个依赖项,则问题是首先加载哪个依赖项(及其传递依赖项),根据Maven Version>2.0.9的依赖项中介规则。其他选项为:"从x管理,重复则省略"。

当我在test-b中运行测试时,尝试访问Enterprise-Data-3.0中的功能时是否会出现错误,因为它不是由服务器-a引入的,还是会因为对Enterprise-Data-3.0存在测试依赖而通过?它当前已通过,但我不确定测试依赖项是否足够。

如果它使用不兼容的代码拉入错误的版本,是的,您将看到错误。对于Maven3,使用3.0定义测试范围依赖项,使用2.4定义编译范围依赖项,这意味着Maven将覆盖2.4,并使用在测试范围中定义的较新的依赖项。有关详细信息,请参阅this question and its answers

不过,您始终可以在test-b中使用依赖项管理来修复要使用的每个依赖项的版本。

这篇关于Maven-从x管理的版本,是否因重复而被省略?的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持IT屋!

查看全文
登录 关闭
扫码关注1秒登录
发送“验证码”获取 | 15天全站免登陆