在PHP8.1上运行WordPress时,字段列表中的未知列 [英] Unknown column 'wp_' in 'field list' when running WordPress on PHP 8.1

查看:54
本文介绍了在PHP8.1上运行WordPress时,字段列表中的未知列的处理方法,对大家解决问题具有一定的参考价值,需要的朋友们下面随着小编来一起学习吧!

问题描述

现在可以在PHP8.1上运行WordPress吗?我已经在XAMPP中安装了PHP8.1,但我无法让WordPress工作。我收到以下错误消息:

[23-Nov-2021 18:44:43 UTC]PHP致命错误:未捕获 MySQLI_SQL_EXCEPTION:中‘field list’中的未知列‘wp_’ C:xampphtdocsmy_php_81_文件夹 Ormal_local_sitewp-包括wp-db.php:2056 堆栈跟踪: #0 C:xampphtdocsmy_php_81_文件夹 Ormal_local_sitewp-包括wp-db.php(2056): MySQLI_QUERY(Object(Mysqli),‘SELECT wp_’) #1 C:xampphtdocsmy_php_81_文件夹 Ormal_local_sitewp--包括wp-db.php(1945): Wpdb-&>do_Query(‘SELECT wp’) #2 C:xampphtdocsmy_php_81_文件夹 Ormal_local_sitewp-adminsetup-config.php(317): Wpdb->;查询(‘SELECT wp_’) #3{main}在C:xampphtdocsmy_php_81_文件夹中抛出 Ormal_local_sitewp-包括wp-db.php 第2056行[23-Nov-2021 18:45:45 UTC]PHP致命错误:未捕获 MySQLI_SQL_EXCEPTION:中‘field list’中的未知列‘wp_’ C:xampphtdocsmy_php_81_文件夹 Ormal_local_sitewp-包括wp-db.php:2056

我已验证正在向此文件夹提供PHP 8.1,并且我可以运行成功创建和修改本地数据库的pdo和mysqli命令。

WordPress

从2021年11月*推荐答案还没有完全兼容PHP8.1。计划于2022年1月25日发布的WordPress 5.9版本应该与PHP 8.1兼容。

暂时,请将PHP 8.0与WordPress一起使用,以避免出现奇怪的错误。

*PHP 8.1于2021年11月25日发布

这篇关于在PHP8.1上运行WordPress时,字段列表中的未知列的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持IT屋!

查看全文
登录 关闭
扫码关注1秒登录
发送“验证码”获取 | 15天全站免登陆