在Windows 10中安装带有JDK 16的NetBeans 12.4中的C/C++插件时出错 [英] Error installing C/C++ plugin in Netbeans 12.4 with JDK 16 in Windows 10

查看:68
本文介绍了在Windows 10中安装带有JDK 16的NetBeans 12.4中的C/C++插件时出错的处理方法,对大家解决问题具有一定的参考价值,需要的朋友们下面随着小编来一起学习吧!

问题描述

我想在NetBeans 12.4和Windows 10中的JDK 16中安装C/C++插件。
安装C/C++插件时出错。

Windows:10
NetBeans:12.4
JDK:16.0.1

我附上的照片:

推荐答案

您遇到此问题是因为NetBeans正在使用JDK 16下载插件,而下载过程依赖于。

由于NetBeans 12.4支持三个JDK版本(8、11和16),因此解决方案是:

  • 暂时将默认平台切换到JDK 8或JDK 11,因为它们支持Unpack 200 API。
  • 当NetBeans在JDK 8或11下运行时,下载并安装C/C++插件。
  • 成功安装C/C++插件后,将NetBeans还原为使用JDK 16。

有关切换到JDK 8或11,然后恢复到JDK 16的详细信息,请参阅How to set the JDK Netbeans runs on?

将NetBeans配置为使用JDK 8或11(我选择了8):

  • 重新启动NetBeans,然后选择工具&>插件&>设置&>添加以将http://updates.netbeans.org/netbeans/updates/8.2/uc/final/distribution/catalog.xml.gz添加为插件的更新中心URL。

  • 单击可用插件选项卡,选中C/C++,然后单击安装按钮安装该插件:

  • 安装插件后,选择文件>;新建项目...,然后从类别列表中选择C/C++以验证插件安装是否正常:

  • 如果列出了所有九种C/C++项目类型(如上所示),则将NetBeans配置为在JDK 16下运行并重新启动NetBeans。

  • 最后,选择文件新建项目...>;C/C++>;C/C++应用程序验证是否可以创建简单的C++应用程序并在JDK 16下运行:

备注:

  • 如果要使用C++17,请参阅How do you enable C++17 in Netbeans?
  • 请注意,根据NetBeans Bug Report NETBEANS-5501中的这条评论,NetBeans目前不支持C++。 :

    目前,NetBeans不支持C/C++,即您的插件 不过,以前/正在使用的8.2版本并未真正得到官方支持 这方面的工作正在进行中,最终目标是正式 NetBeans的一部分,但这将需要一段时间

这篇关于在Windows 10中安装带有JDK 16的NetBeans 12.4中的C/C++插件时出错的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持IT屋!

查看全文
登录 关闭
扫码关注1秒登录
发送“验证码”获取 | 15天全站免登陆