adt相关内容

安装依赖项未在 ADT r20 中解决

我只是将我的 ADT 和 SDK 更新到 SDK 中最新版本的 ADT r20 和 Android 4.1. 现在在 Eclipse 中,我无法创建一个带有默认 BlankActivity 的新项目. 在新项目对话框中,我坚持最后一个屏幕,其中提到有 android 支持库修订版 8 所需的“安装依赖项"为此. 我已经在 SDK 中安装了修订版 9.我还点击了“安装/升级"按钮, ..
发布时间:2021-11-27 21:13:39 移动开发

未使用 New->Android Activity Wizard 创建空白活动

我最近将我的 Android SDK 从 22.3 更新到 22.6.更新后,我尝试使用向导创建一个空白活动.我无法像之前创建的那样创建一个.此外,我无法创建 LoginActivity 或 Settings Activity 等. 我以某种方式设法通过向导创建了 Activity,我发现我的类没有扩展简单的 Activity,而是扩展了其他东西. 有没有其他人遇到过这样的问题? ..
发布时间:2021-11-27 21:13:20 移动开发

更新到 Android SDK 工具 23.0.5 并且 avd 无法启动

我在 Windows 8.1 x64 上运行,使用 ADT Bundle 开发 Android 应用程序.以前(在更新 Android SDK 工具之前)AVD 工作非常正常,更新后,它在启动 AVD 时显示以下错误 emulator: ERROR: x86 emulation 当前需要硬件加速!请确保英特尔 HAXM 已正确安装和可用.CPU加速状态:未安装HAX内核模块! 我尝试从 Win ..
发布时间:2021-11-27 21:12:26 其他开发

无法执行dex:多个dex文件定义了Lcom/myapp/R$array;

自从更新到 ADT 14 后,我无法再构建我的项目.它在更新之前构建良好. 错误: [2011-10-23 16:23:29 - Dex Loader] 无法执行dex:多个dex文件定义了Lcom/myapp/R$array;[2011-10-23 16:23:29 - myProj] 转换为 Dalvik 格式失败:无法执行 dex:多个 dex 文件定义了 Lcom/myapp/R$ ..
发布时间:2021-11-27 21:09:09 移动开发

为什么在我以前从未需要它时开始使用 -libraryjars?

自从我将 ADT 从 16 更新到 18(这要求 Proguard 从 4.6 更新到 4.8)以来,Proguard 的行为一直非常奇怪(并且不一致?). 最近出现的此类问题是,当我尝试导出已签名(发布)APK 时,收到以下错误: Proguard 返回错误代码 1.见控制台警告:com.bta.LibProj2:找不到引用的类 com.bta.R$string警告:com.bta.My ..
发布时间:2021-11-27 20:38:00 移动开发

Android NDK 构建,方法无法解析

我有一个带有本机代码的 Android 项目.我可以通过调用 ndk-build 命令从命令行构建本机代码,没有错误或警告.但是当我在 ADT 中打开它时,它显示以下错误. 错误信息:Method CallStaticIntMethod 无法解析. 项目中有很多类似错误的文件. 我仔细检查了配置,这就是我所拥有的.Android 构建、工具链和包含已正确配置(见下图) 所需的包含 ..
发布时间:2021-11-27 20:03:48 Java开发

来自 nativeGetEnabledTags 的意外值:0

我安装了最新版本的 SDK (r21) 和 ADT 21.0.0.我尝试了简单的代码,它运行良好,但现在我在 LogCat 在以前的版本中没有出现: 来自 nativeGetEnabledTags 的意外值:0 我用谷歌搜索,我发现问题 39723:模拟器垃圾邮件 LogCat 并带有“意外"来自 nativeGetEnabledTags 的值:0" 消息. 什么意思? 解 ..
发布时间:2021-11-27 19:12:16 移动开发

使用新的“manifestmerger"Android 中的属性

在最新版本的 ADT(第 20 版预览版 3)中,他们说可以使库的清单文件与使用它们的项目合并: 自动将库项目清单文件合并到包含项目清单.使用 manifestmerger.enabled 属性启用. 我如何以及在哪里使用它?我在任何地方都看不到内容帮助帮助我解决这个问题. 解决方案 将以下行添加到您的应用程序项目的 project.properties 文件中. manif ..
发布时间:2021-11-27 18:30:47 移动开发

从android源构建警报应用程序时出错

我想构建一个扩展基本闹钟功能的应用程序.由于我没有在闹钟功能中发明任何轮子,我想使用公开可用的 android 默认闹钟. 然而,我已经尝试多次构建它,但错误太多(提到 此处也): 我也尝试了这种方法,但我仍然无法构建它. 任何人都可以指导如何构建 git android tree 中提供的 android 应用程序. 我提到的链接: 闹钟代码:mContext 变量 ..
发布时间:2021-11-27 13:26:27 移动开发

无法从 Eclipse、ADT 22.6 创建或编辑 Android 虚拟设备 (AVD)

这个问题听起来类似于少数 其他,除了在我的情况下,确定按钮没有变灰.但对于那些不想点击链接的人... 尝试在 Eclipse 中创建或编辑 AVD,在输入我的设置后,“确定"按钮似乎是“可点击的",但是当我点击它时绝对没有任何反应. 我已确保安装了适当的系统映像,并且目标平台与正在使用的 API 相匹配.显然已经选择了 CPU、皮肤设置等......所有会使 OK 按钮变灰的事情,但事 ..
发布时间:2021-11-25 14:15:37 Java Web开发

使用 Android 开发工具 v. 23 更新 Eclipse

我使用新的 SDK 工具(修订版 23)更新了 Eclipse,但是现在当 Eclipse 启动时我收到错误: 此 Android SDK 需要 Android Developer Toolkit 23.0.0 或更高版本.当前版本为 22.6.3.v201404151837-1123206.请将 ADT 更新到最新版本. 未通过“检查更新"找到更新.如果我尝试“安装新软件",我可以看 ..
发布时间:2021-11-25 11:32:57 Java Web开发

如何将 javadoc 或源文件附加到 libs 文件夹中的 jars?

用于 Eclipse 的新版 ADT r17 插件添加了自动设置 JAR 依赖项的功能./libs 文件夹中的任何 .jar 文件现在都添加到构建配置中.不幸的是,Android Dependencies 类路径容器是不可修改的. 如何将 javadoc 和源文件附加到自动插入的 .jar(来自/libs 文件夹)? 解决方案 回答问题的最佳方式是总结 Xavier、plastiv、 ..
发布时间:2021-11-22 16:58:44 Java Web开发

无法使用 L SDK 的某些功能

我正在尝试在新 SDK 中使用新的活动转换. 我试过这条线: getWindow().requestFeature(Window.FEATURE_CONTENT_TRANSITIONS); 但问题在于 Window 不包含 FEATURE_CONTENT_TRANSITIONS. 我也试过这条线: getWindow().setExitTransition(new Explode ..
发布时间:2021-11-21 21:07:06 Android

ADT (Eclipse) vs. Android Studio:APK 文件大小相差多少是正常的?

我将 ADT 项目导入到最新版本的 Android Studio (0.6.1).这两个项目共享相同的代码和库.此外,这两个项目都已清除并在启用相同 ProGuard 设置的情况下进行编译. 但 ADT APK 文件大小为 1.8 MB,Android Studio APK 文件大小为 2.7 MB. 这种 APK 文件大小增加 50% 是否被认为是正常的,因为 Android Stu ..
发布时间:2021-11-21 21:04:03 Android

Android Studio - 平板电脑模拟器没有显示正确的分辨率

刚刚创建了一个 Nexus 10 模拟器,但是当我启动它时,显示了错误的分辨率.当它应该显示为 2560 x 1600 时,它一直显示为 800 x 1280.有谁知道到底发生了什么以及如何解决这个问题? 解决方案 根据 OP 的要求, 在创建 AVD 的最后一步,转到高级设置并选择合适的皮肤(或者最好选择“无皮肤"选项) 以确保它具有您想要的分辨率. ..
发布时间:2021-11-21 20:34:51 Android

Eclipse ADT 捆绑包链接在哪里?

在 Android 开发的官方网站上,我再也看不到 Eclipse ADT 包的链接了. 我无法切换到 Android Studio,因为我的框架目前是基于 Ant 而不是基于 Gradle. 我是否需要单独下载 Eclipse 和 ADT 插件,或者是否有 Eclipse ADT 捆绑链接(如果它仍然存在)? 解决方案 这里可以下载adt bundles 2014-07-02 ..
发布时间:2021-11-21 20:27:25 Android

AndroidStudio 中的 NDK 支持以及在 Android Studio 和 Eclipse 之间进行选择

我在 Android Studio 和 Eclipse 之间进行选择时遇到了“竞争条件": 我的项目需要一些 C++ 代码才能与我的应用程序链接.目前,Android Studio 1.0 不支持 NDK(已弃用?!).说弃用并不能揭示整个丑陋的画面.目前还不清楚如何将预编译的 .so 库链接到项目.更不用说编译了...虽然很多解决方案每天都在stackoverflow中发布.大多数都与一些 ..
发布时间:2021-11-21 19:52:13 Android