android-sdk-tools相关内容

安装依赖项未在 ADT r20 中解决

我只是将我的 ADT 和 SDK 更新到 SDK 中最新版本的 ADT r20 和 Android 4.1. 现在在 Eclipse 中,我无法创建一个带有默认 BlankActivity 的新项目. 在新项目对话框中,我坚持最后一个屏幕,其中提到有 android 支持库修订版 8 所需的“安装依赖项"为此. 我已经在 SDK 中安装了修订版 9.我还点击了“安装/升级"按钮, ..
发布时间:2021-11-27 21:13:39 移动开发

如何使用 Eclipse 导出 APK 文件?

在Eclipse中使用Android Tools导出Application Package有两种方式- 导出未签名的应用程序包 导出已签名的应用程序包 解决方案 使用Eclipse生成APK文件的步骤- 转到文件>导出 在“导出"窗口中,转至 Android > 导出 Android 应用程序. 点击浏览...并选择要导出的 Android 应用程序项目. ..
发布时间:2021-11-27 21:13:28 Java开发

未使用 New->Android Activity Wizard 创建空白活动

我最近将我的 Android SDK 从 22.3 更新到 22.6.更新后,我尝试使用向导创建一个空白活动.我无法像之前创建的那样创建一个.此外,我无法创建 LoginActivity 或 Settings Activity 等. 我以某种方式设法通过向导创建了 Activity,我发现我的类没有扩展简单的 Activity,而是扩展了其他东西. 有没有其他人遇到过这样的问题? ..
发布时间:2021-11-27 21:13:20 移动开发

如何使用 jobb 工具创建 .obb 文件作为主 apk 扩展文件?

我有一个 80Mb 的 apk,因此无法将其上传到 Google Play 商店.我用谷歌搜索了很多,发现我必须创建 .obb 文件作为主要的扩展文件. 我还发现我可以使用 .obb 文件="nofollow noreferrer">jobb 工具,它在 sdk > 中工具 >jobb.bat 但不幸的是它在启动后立即关闭. 所以我错过了什么吗? 解决方案 我用谷歌搜索,发现我 ..
发布时间:2021-11-27 21:13:10 移动开发

缺少 SDK 平台 Android、API 18

当我尝试安装 API 18 时,它只显示 "Google API 18"(仅此而已).现在,如果我尝试从 Android SDK Manager 安装这些 google API,它会显示一条消息 “此包依赖于“缺少 SDK 平台 Android,API 18".安装按钮是已禁用. 这里有人知道如何使用 Eclipse 安装 API 18(4.3_MR2 sdk) 解决方案 您是否安装 ..
发布时间:2021-11-27 21:13:03 移动开发

SDK 管理器无法安装“java.exe"锁定目录

我在尝试将 Android SDK Tools 从 revision 20.0.3 更新到 revision 21 时遇到了一个奇怪的错误.ADT 插件正确更新,所以现在我一直在等待解决. 我列出的初始错误 cmd.exe &java.exe 作为锁定目录,我强制关闭 cmd.exe 并得到这个: 如果我强制关闭 java.exe 那么显然我的 SDK 管理器会关闭. SDK 管 ..
发布时间:2021-11-27 21:12:54 移动开发

无法定位 Android SDK

我已经安装了 android studio 和 android sdk,后来我添加了 flutter 和 flutter sdk.这是我的问题:当我跑步时 >扑医生 它显示了 我没有安装 Android SDK. 解决方案 您可以使用 为您的项目配置 Android SDK flutter 配置 --android-sdk/path/to/android/sdk PATH ..
发布时间:2021-11-27 21:12:34 移动开发

更新到 Android SDK 工具 23.0.5 并且 avd 无法启动

我在 Windows 8.1 x64 上运行,使用 ADT Bundle 开发 Android 应用程序.以前(在更新 Android SDK 工具之前)AVD 工作非常正常,更新后,它在启动 AVD 时显示以下错误 emulator: ERROR: x86 emulation 当前需要硬件加速!请确保英特尔 HAXM 已正确安装和可用.CPU加速状态:未安装HAX内核模块! 我尝试从 Win ..
发布时间:2021-11-27 21:12:26 其他开发

Qt Creator Android 错误“已安装平台 SDK"

我正在为 Android 开发 Qt 跨平台应用程序,最近我更新了 Qt 创建者并安装了新的 Qt 版本.我正在使用 'Qt Creator version 4.5.0'.我已经更新到'QT version 5.10'.此设置在 Ubuntu 16.04 上完成. 跟随链接QT 安装入门. 我总是在 Qt Creator->Tools->Options->Devices->Androi ..
发布时间:2021-11-27 21:12:18 移动开发

如何让 Visual Studio 2015 安装程序知道我已经拥有 Android SDK?

当我安装 Visual Studio 2015 时,我意识到计算机上已经存在 Java SE Development Kit.我认为安装程序知道它是因为环境变量.这就是我设置 ANDROID_SDK_HOME 和 ANDROID_NDK 环境变量的原因. 但是当我再次启动安装程序时,它仍然只知道 Java Development Kit. 我是否设置了错误的环境名称?如何让安装程序知道 ..
发布时间:2021-11-27 21:11:44 其他开发

无法打开 Android SDK 管理器

在这里和其他地方搜索了我的问题的答案,我仍然无法解决这个问题. 我已经安装了 Eclipse、ADT 插件和 Android SDK.我的问题是无论是从 Eclipse 启动还是直接启动,SDK 管理器都不会打开.命令提示符窗口短暂闪烁,然后关闭. 我尝试了几种建议的解决方案:我的 Path 和 JAVA_HOME 变量的各种配置,安装 32 位和 64 位版本的 JDK,以管理员身份 ..
发布时间:2021-11-27 21:11:27 移动开发

从 sdkmanager CLI 截断的 Android SDK 包路径

./sdkmanager --list >tmp.txt 给了我一个这样的 .txt 文件: 安装的包:路径 |版本 |说明 |地点------- |------- |------- |-------工具|25.2.3 |Android SDK 工具 25.2.3 |工具/可用套餐:路径 |版本 |描述------- |------- |-------附加组件;addon-g..._apis-g ..
发布时间:2021-11-27 21:11:17 其他开发

Cordova:[错误:请安装 Android 目标:“android-21";

我刚刚在我的应用程序中更新了cordova + ionic,之后我通过Android SDK manager成功安装了Android-SDK v22. 但是在运行命令之后: cordova 构建 android 我总是收到以下消息: 运行命令:/Users/peter/workspace/myapp/platforms/android/cordova/build[错误:请安装 Andr ..
发布时间:2021-11-27 21:11:09 移动开发

没有 NDK 版本与请求的版本匹配

更新到 Android Gradle 插件 3.6.0(2020 年 2 月 24 日发布)后,几个项目独立开始失败: 没有与请求的版本 20.0.5594570 匹配的 NDK 版本.本地可用版本:21.0.6113669 通过安装较旧的预期 ndk 版本在本地“修复"此问题非常简单: sdkmanager 'ndk;20.0.5594570' 但是,我的问题是:这个旧版本在哪里以及如何 ..
发布时间:2021-11-27 21:11:02 移动开发

Eclipse 不生成 MainActivity.java &活动_main.xml

在创建一个新的Android应用程序项目时,src文件夹&中应自动生成其包名下的MainActivity.javaactivity_main.xml 应该在 layout 文件夹中创建.但它没有被创建. 而且在清单中它也不会生成这个 POC “检查更新",然后我收到一条弹出消息,说一切都是最新的,但经过进一步研究,我发现它不是最新的.您需要做的是单击“帮助"->“安装新软件"并从此网址安 ..
发布时间:2021-11-27 21:10:53 Java开发

Android Hello-World 编译错误:Intellij 找不到 aapt

我正在尝试在 Ubuntu 12.04 中使用 IntelliJ 设置 Android 开发环境.我创建了一个 Android 应用程序模块,但是当我尝试构建时,出现以下错误: android-apt-compiler: 无法运行程序 "/home/jon/Programs/android-sdk-linux/platform-tools/aapt": java.io.IOException ..
发布时间:2021-11-27 21:10:42 移动开发