info.plist相关内容

Xcode 6/iOS - 存档 &Info.plist 缺失

我正在尝试为 iOS 应用创建和验证存档.我可以在模拟器上运行并创建存档,但是当我尝试验证存档时,我收到以下消息: 在构建设置中似乎正确设置了 plist 位置(当我更改它时,我无法再在模拟器上运行). 有什么遗漏的线索吗? 谢谢 解决方案 好吧,我只需要在我的项目信息的“常规"选项卡中设置“构建"和“版本".手动设置plist中的值不起作用-_- ... ..
发布时间:2021-11-17 03:18:49 其他开发

由于第三方库,如何处理 AppStore 警告 - 缺少目的字符串?

我已经上传了在 App Store 中存在多年的应用程序的新版本. 从 iTunes Connect 收到以下电子邮件: 您的交付成功,但您可能希望在下次交付时更正以下问题:ITMS-90683:Info.plist 中缺少目的字符串 - NSLocationAlwaysUsageDescriptionNSLocationWhenInUseUsageDescription ..
发布时间:2021-11-17 00:56:00 其他开发

“my_app.app/ResearchKit/ResearchKit/Info.plist"中的包不包含包可执行文件

更新XCode 版本:8.2iOS 目标:9 希望有人能向我指出这不是错误.很简单,我拉取了最新稳定版本的 researckKit,并将 .xcodeproj 文件放入我的新 iOS 项目中,添加了嵌入式二进制文件.我创建了几个在模拟器中看起来不错的步骤.我的应用程序构建良好,甚至存档验证正常.上传到应用程序商店很好,但后来我收到来自应用程序商店的电子邮件,其中 6 个条目看起来都差不多,对 ..
发布时间:2021-11-17 00:54:54 其他开发

info.plist 中的 CFBundleShortVersionString 必须高于 1.0

我在 App Store 上传了应用程序,现在它处于“待开发者发布"状态.但我想在发布前将其提供给测试人员.我对内部测试人员没有任何问题,我让他们可以毫无问题地访问应用程序.但是我在使用相同二进制文件的外部测试人员时遇到了麻烦.有错误: info.plist 中的 CFBundleShortVersionString 必须大于 1.0 如果我不想重新加载二进制文件,我该怎么办,因为我可 ..
发布时间:2021-11-17 00:38:17 其他开发

找不到文件 *.storyboardc

我正在尝试提交带有扩展程序的 iOS 应用程序,但在验证时遇到一个奇怪的错误: 我的小部件故事板名为 Main.storyboard.属性文件如下所示: 解决方案 我想这是一个错误.当我将 Main.storyboard(在 info.plist 中定义的 NSExtensionMainStoryboard)移动到扩展目标的子目录时,我解决了这个问题.这意味着您不能本地化 main. ..
发布时间:2021-11-17 00:36:42 其他开发

错误 Appstore 连接:Info.plist 文件中缺少目的字符串

我已将我的应用提交给 App Store Connect 以供审核.尽管该应用程序仍在审核中,但我已收到一封电子邮件,通知我必须修复错误.以下是邮件内容: 亲爱的开发者: 我们发现您的应用最近交付的一个或多个问题XXXXX.您的交付成功,但您可能希望更正下次交付时出现以下问题: “Info.plist 文件中缺少目的字符串.您的应用程序代码引用一个或多个访问敏感用户数据的 API ..
发布时间:2021-11-17 00:06:19 其他开发

捆绑包使用与 Apple 应用关联的捆绑包名称或显示名称

在将我的应用提交到应用商店进行升级时,我收到一条验证警告,指出我的应用不能与 Apple 应用具有相同的捆绑显示名称. 一个巧妙的方法是在包显示名称的末尾添加一个特殊字符.例如:Compass 可以是 Compass!、Compass+、Compass. 雅虎!天气在其捆绑显示名称后有一个整洁的项目符号点.有谁知道如何将该字符添加到您的包显示名称中? 解决方案 解决此问题的一个 ..
发布时间:2021-11-17 00:02:29 其他开发

AppStore语言说明和“本地化原生开发区"

以三种语言(英语、意大利语和西班牙语)本地化的 iPhone 应用已提交到 AppStore,并附有这三种语言的描述和屏幕截图.结果是,在美国 AppStore 中有英文说明,在西班牙 AppStore 中有西班牙文说明,在意大利 AppStore 中有意大利文说明,但在所有其他 AppStore 中,语言说明是意大利文. 我认为问题是在info.plist文件中,“本地化本地开发区域"条目 ..
发布时间:2021-11-16 23:36:51 其他开发

App Store:UIRequiredDeviceCapabilities 的问题

我已将我的第一个应用程序上传到 App Store,但我没有设置我的应用程序需要位置服务和 wifi 的 UIRequiredDeviceCapabilities.结果:应用程序没有像它应该做的那样开始寻找坐标.(当我通过 iPhone 4 中的 XCode 安装该应用程序时,它运行良好. 因此,我尝试上传正确设置此 UIRequiredDeviceCapabilities 的新版本,但在尝 ..
发布时间:2021-11-16 23:34:51 其他开发

错误 Appstore 连接:Info.plist 文件中缺少目的字符串

我已将我的应用提交给 App Store Connect 以供审核.尽管该应用程序仍在审核中,但我已收到一封电子邮件,通知我必须修复错误.以下是邮件内容: 亲爱的开发者: 我们发现您的应用最近交付的一个或多个问题XXXXX.您的交付成功,但您可能希望更正下次交付时出现以下问题: “Info.plist 文件中缺少目的字符串.您的应用程序代码引用一个或多个访问敏感用户数据的 API ..
发布时间:2021-11-16 23:25:47 其他开发

“应用程序需要 iPhone 环境"是什么意思?键入 info.plist?

我无法理解我的应用程序中 info.plist 文件中的具体要求.我应该完全改变它,还是默认设置通常是“正确"的选项? 具体来说,条目:APPLIS REQUIRES IPHONE ENVIRONMENT 如果设置为 yes,是否意味着只有 iPhone 能够运行我的应用程序,这意味着 iPod Touch 或 iPad 将无法运行该应用程序? 解决方案 这里是 Apple 关 ..
发布时间:2021-11-16 22:18:43 其他开发

如何阻止 Xcode 11 将 CFBundleVersion 和 CFBundleShortVersionString 更改为 $(CURRENT_PROJECT_VERSION) 和 $(MARKETING_VERSION)?

自版本 11 起,Xcode 将我的 CFBundleVersion 值设置为 $(CURRENT_PROJECT_VERSION) 并将我的 CFBundleShortVersionString 值设置为 $(MARKETING_VERSION) 每当我在目标设置(标签“常规")中输入版本或构建值时. 我输入的实际版本和构建值现在存储在 project.pbxproj 文件中.我不想要或不 ..
发布时间:2021-09-30 20:30:38 其他开发

Xcode/iOS - CFBundleAlternateIcons 没有改变

我一直在尝试使用 CFBundleAlternateIcons 更改我的应用程序图标,但没有任何反应.我实际上正在使用 Flutter SDK 的插件 - flutter_dynamic_icon,当我使用该插件更改图标时,它显示“应用程序图标更改成功",好像没有任何问题. 在进行了一些故障排除后,我还尝试在预览中重新保存图标以确保它们是 PNG 文件,并删除了它们的 Alpha 通道,结果 ..
发布时间:2021-09-30 20:15:33 其他开发

在 ios 应用程序中飞溅

我正在不受限制地处理旧项目和此启动图像. 默认-568h@2x.png 640 x 1136默认.png 320 x 480默认@2x.png 640 x 960 没有 Images.xcassets 目录,也没有像 这篇文章. 这一切都给我留下了深刻的印象,因为我从未见过这样的东西. 调查所有这些,我意识到我必须做任何事情才能使它工作,只需要使用这些特定名称的 splash 并且 ..
发布时间:2021-09-30 20:11:52 其他开发

在 Info.plist 中指定设备系列

有没有一种方法可以仅根据 Info.plist 中的键来指定设备系列,而无需更改构建设置?我已经阅读了 UIDeviceFamily 在构建时被自动添加到 Info.plist 的信息,并且文档说我不应该手动添加这个键.假设我不能使用 Xcode,但我可以编辑 Info.plist,有没有办法指定应用程序是否应该只在 iPhone(或 iPad)上运行? 谢谢, 解决方案 查看 UI ..
发布时间:2021-09-30 19:34:05 其他开发

Xcode 中缺少 C++ 命令行工具应用程序的 info.plist 文件

我想用 opencv 为大学课程创建一个相机校准应用程序.我在 macOS High Sierra 上创建了一个命令行工具应用程序.不幸的是它没有 info.plist 文件.我的应用程序崩溃并显示以下错误消息: CameraCalibration[2314:193066] [access] 此应用程序崩溃,因为它试图在没有使用说明的情况下访问隐私敏感数据.应用程序的 Info.plist ..
发布时间:2021-09-30 19:19:27 其他开发

Xcode 无法打开 Info.plist -- 错误提示“没有这样的文件";

我切换到 Xcode 4 并加载了我的项目,它在 Xcode 3 中完美运行.当我运行它时,我收到一条错误消息: 无法打开文件“Info.plist",因为没有这样的文件. 我在 Xcode 中查看了该文件,它就在那里.那为什么打不开呢? 解决方案 该文件存在于您的 Xcode 项目文件夹中是不够的.您是否已验证在您的应用程序目标的构建设置中正确引用了该文件,以便将其正确复制到 ..
发布时间:2021-09-30 19:13:31 其他开发

修复文件“project.pch"已被修改,因为预编译头文件在 Xcode 中构建错误

我最近在 info.plist 部分处理我的应用程序,因为我的应用程序无法在我的测试设备上运行: 文件“project.pch"自构建预编译头以来已被修改 需要注意的是,该应用程序在模拟器中运行良好. 编辑:现在我收到这个错误而不是另一个错误: 没有那个文件或目录 (/Users/Me/Library/Developer/Xcode/DerivedData/MyProjec ..
发布时间:2021-09-30 19:09:15 其他开发

Xcode 10 错误:产生多个命令

错误:多个命令产生“/Users/uesr/Library/Developer/Xcode/DerivedData/OptimalLive-fxatvygbofczeyhjsawtebkimvwx/Build/Products/Debug-iphoneos/OptimalLive.app/Info.plist":1) 目标“OptimalLive"具有从“/Users/uesr/Desktop/w ..
发布时间:2021-09-30 19:07:30 其他开发