internet-explorer-9相关内容

不使用 Zip 文件下载多个文件

我有一个通用处理程序 Document.ashx,它通过从查询字符串中读取信息来动态创建 Word 文档,例如 Document.ashx?clientid=123&documentid=10 并且效果很好. 我需要创建一个带有复选框列表和一个全部下载按钮的界面.到目前为止,我最好的想法是使用这样的方法来调用处理程序. $("body").append(" ..
发布时间:2021-11-28 23:09:54 C#/.NET

IE9 WebBrowser Control 是否支持 IE9 的所有功能,包括 SVG?

我最近升级到 IE9-beta.现在,在我的 .Net (3.5) WinForm 应用程序中,我想使用 WebBrowser 控件. 那么我的问题是,WebBrowser控件是否会展示IE9的所有属性和功能? 我担心的是,我想在上面渲染一些 SVG 图形. 解决方案 WebBrowser 控件的 IE9“版本"与 IE8 版本一样,实际上是多个浏览器合二为一.与 IE8 版本 ..
发布时间:2021-11-26 09:51:13 C#/.NET

如果由 jQuery 设置,CSS3 2D 变换在 IE9 上不起作用

根据标题,我正在使用 CSS3 的变换来平移和旋转对象,它在除 IE9 之外的所有浏览器中都能完美运行. 它适用于 IE9 但前提是它直接写入 .css 文件.如果由 jQuery (v. 1.5.1) 设置,则失败: $('#example').css('-ms-transform', 'translate(200%) rotate(45deg) translate(-200%)'); ..
发布时间:2021-11-24 22:23:44 C#

YouTube iframe API - onReady 和 onStateChanged 事件未在 IE9 中触发

数小时以来,我一直在进行故障排除并寻找答案,但无济于事.正在逐字使用 API 文档中的示例代码.其他人在 IE9 上发布和说的示例代码不适合我.我已经确认在 html 中正确设置了 doctype,我没有在 CSS 中使用 display=none 隐藏 iframe,浏览器模式是 IE9,文档模式是 IE9 标准.我的安全设置被配置为中高.在我的 IE9 浏览器中,即使是 google 的示例页 ..
发布时间:2021-11-15 00:54:30 其他开发

Angular UI-Router 无法使用 Internet Explorer 9 解析

我有一个 Angular v1.3 应用程序,它使用 Angular ui-router v0.2.13 进行所有路由.该站点适用于所有浏览器,包括 IE 10 和 IE 11,但不适用于 IE 9(我们决定不追求 IE8,我知道 v1.3 不支持,无论如何).尽管我尽了最大的努力,IE 9 还是不断地解析到我的 $stateProvider's otherwise 路由(设置为 /*path,一 ..
发布时间:2021-11-10 04:43:43 其他开发

使用 IE9 的 Blueimp 文件上传器

我正在 AngularJS 应用程序中使用此插件将文件上传到 REST API.当“fileuploaddone"事件触发几秒钟后,我收到来自 Internet Explorer 的黄色通知,内容为:您要保存\打开 附上截图. 解决方案 基于 iframe 的上传要求 JSON 响应的内容类型为 text/plain 或 text/html - 如果 iframe 响应设置为 a ..
发布时间:2021-11-09 04:29:15 其他开发

IE 9 不支持 $locationProvider.html5Mode

嗨,我正在创建一个 angularjs 应用程序.我将 $locationProvider.html5Mode 设为 true.现在我得到了没有 # 的漂亮网址.它在 chrome 和 firefox 中运行良好.但是当我尝试在 IE 9 中打开它时,它一直在重新加载. 解决方案 坏消息.IE9 不支持 HTML5 History API.这就是 angular html5Mode 使用的 ..
发布时间:2021-11-09 04:13:57 其他开发

AngularJS 如何使用路由删除 IE9 中的 # 符号

我无法删除 IE9 中的 # 符号.我搜索了答案,但没有找到解决方法. 这总是重定向到 http://myhost.com:8080/#/website/ 并显示此描述: 请求的资源不可用. locationprovider.html5mode(true) 不起作用.相同的路线在 FireFox 中工作并显示 http://myhost.com:8080/website/ 我该如 ..
发布时间:2021-11-09 03:05:07 其他开发

简单的 jQuery(scrollTo 和 animate)在 IE 中不起作用

我刚刚注意到一些简单的 jQuery 不适用于移动版 IE9 和 IE10.我有一些版权链接和使用 animate() 的简单滑动联系表单.此外,我将 scrollTo 插件与 jQuery 结合使用.我尝试了不同的版本,仍然没有解决方案.也许我遗漏了一些明显的东西. 这是一个版权链接和用于打开和关闭联系表单的代码. $('#privacy').click(function(){$('#c ..
发布时间:2021-10-26 17:05:27 其他开发

css3 旋转在 IE9 中不起作用

这段代码允许我在鼠标悬停在其中一个图像上时缓慢旋转图像. .foo img {-webkit-transition:所有 0.5 秒轻松;-moz-transition:所有 0.5 秒轻松;-o-transition:所有 0.5 秒的缓和;-ms-transition:所有 0.5 秒轻松;过渡:全0.5s缓动;}.foo img:悬停{-webkit-transform:旋转(-10度) ..
发布时间:2021-07-10 19:41:06 其他开发

IE7 IE8 IE9颜色:透明属性

我可能没有足够的信息来在这里提出一个完整的问题,但是如果有人有想法或需要更多信息在评论中提问,我将试一试,我将尝试获取尽可能多的信息. 我正在处理一些我未编写的代码中的问题.该页面使用javascript日期选择器,并将该日期放入输入框.遍历代码并按f12键,将属性从 更改为 style ="color:transparent" 到 style ="color:black" ..
发布时间:2021-05-16 19:44:53 其他开发

从HTA应用程序打开程序

我正在尝试创建一个HTA应用程序,该应用程序可以在计算机上本地打开程序(exe,bat等.). 这将在用户无法访问台式机等的Kiosk PC上使用. 但是在查找有效的脚本时会遇到一些问题. 现在我正在使用此脚本: 函数runApp(哪个){WshShell = new ActiveXObject("WScript ..
发布时间:2021-05-16 19:44:41 其他开发

IE9 ReactJs中未定义“设置"或“映射"

我用react 16.2.0创建了一个简单的应用程序,当我在IE9上执行/运行它时,显示控制台错误'Set'或'Map'未定义. 解决方案 我发现需要一些polyfill才能在IE9上运行我的react应用程序.我遵循以下步骤,它为我工作.由于React 16取决于集合类型Map和Set.如果您支持可能还没有原生提供这些功能的较旧的浏览器和设备(例如IE ..
发布时间:2021-05-16 19:44:36 其他开发

无法从释放的脚本中执行代码-IE6 IE7 IE8 IE9

我今天在IE6中遇到了这个问题(但在所有最新版本的IE中都可以重现). 我注意到有很多人遇到了这个问题,但还没有找到解决该问题的非常实用的方法. 关于HTML文档开头的脚本标签和元标签的顺序,似乎还有其他解决方案.我还没有确认,但是无论如何这是一个链接:导致错误的原因“无法执行"释放脚本中的代码" 我也知道该问题的解决方案,所以我将其发布在下面 解决方案 首先,您需要找到 ..
发布时间:2021-05-16 19:44:32 其他开发

IE9,IE8,SVG,VML和doctypes

我正在用ASP.NET Web应用程序绘制图形.在IE9和其他浏览器中,我正在使用SVG进行操作,并且效果很好.在IE8及以下版本中,我正在使用VML.我发现在IE8标准模式(不使用兼容性视图)下,IE8根本不显示VML. 我的文档类型设置为 .如果我完全删除了doctype,则IE8会进入quirks模式,并且可以正常工作,但是IE9然后会进入其 quirks ..
发布时间:2021-05-16 19:37:54 其他开发

为什么.fireEvent()在IE9中不触发?

在IE9上,这真是令人沮丧的时间.该代码在IE7/8中有效,但在9中无效. document.getElementById('id').fireEvent("OnChange"); 对为什么有任何见识? 解决方案 在IE版本> = 9和所有其他浏览器中,应使用 dispatchEvent 方法: var event = document.createEvent("HTMLEve ..
发布时间:2021-05-02 20:22:48 其他开发

如何使Bootstrap 4与IE9和IE10兼容

哪些polyfill库可用于使Bootstrap 4(或Bootstrap 4的大多数)与IE9配合使用? 我遇到过这些库: https://github.com/jonathantneal/flexibility https://github.com/coliff/bootstrap-ie8 谢谢. 解决方案 查看他们的网站,他们建议使用Bootstrap 3来支持I ..
发布时间:2021-04-16 18:35:26 其他开发