rvm相关内容

Web 应用程序无法启动乘客错误 (Apache2) - 引用不存在的 Ruby 补丁

使用最新版本的 RVM 从 p247 更新到 Ruby 2.0.0 (P353) 的最新补丁后,我遇到了问题.这是我的原始问题的链接,我遇到了旧补丁的 RVN 环境文件丢失的问题,该补丁不再存在于我的系统中.RVM 已更正,该问题消失了. 错误:之后缺少 RVM 环境文件做rvm升级命令-Passenger 4.0.23 我继续使用我的Passenger Enterprise 帐户中的 ..
发布时间:2021-11-11 22:15:05 其他开发

Ansible 权限问题

我正在尝试将当前用户添加到系统中的一个组,然后执行需要该组权限的命令.我的剧本是这样的: - name:将此用户添加到 RVM 组须藤:真的用户:state=present name=vagrant append=yes groups=rvm group=rvm- 名称:安装 Ruby 1.9.3命令:rvm install ruby​​-1.9.3-p448 created=/usr/loca ..
发布时间:2021-11-11 01:33:26 其他开发

Ansible 权限问题

我正在尝试将当前用户添加到系统中的一个组,然后执行需要该组权限的命令.我的剧本是这样的: - name:将此用户添加到 RVM 组须藤:真的用户:state=present name=vagrant append=yes groups=rvm group=rvm- 名称:安装 Ruby 1.9.3命令:rvm install ruby​​-1.9.3-p448 created=/usr/loca ..
发布时间:2021-11-11 00:27:17 其他开发

rvm 系统安装,bin 没有正确符号链接

我在 ubuntu 12.04 上安装了 rvm 系统: $ \curl -L https://get.rvm.io |sudo bash -s 稳定 到目前为止,我一直执行单用户安装,老实说,我对系统范围安装的结果感到很困惑. 它确实将 rvm bin 目录放在我的路径中,但它用不能直接使用的名称符号链接了所有二进制文件. 这是否意味着我应该将它们一一符号链接? 有什么问题吗? ..
发布时间:2021-09-12 19:13:10 其他开发

如何在 os x 服务器上通过 ssh 更改 rvm gemset

好的 我不知道如何在 os x 服务器下通过 ssh 更改 rvm 版本. 我做什么: 通过 ssh 登录服务器 运行脚本(如下)并捕获错误 错误:“rvm 不是一个函数,很多词" 我的脚本: 使用 File::Spec;my $server_directory = File::Spec->catfile($ENV{HOME},'MyProject');我的 $exe ..
发布时间:2021-07-14 18:48:21 其他开发

当我打开一个新的终端窗口时,如何告诉 RVM(Ruby 版本管理器)记住我设置的默认值

我使用 RVM 安装 Ruby 2.5.1,并将其设置为默认值.但是,当我打开一个新的终端窗口并输入 which ruby​​ 时,我得到了我机器的 Ruby 的路径,而不是我设置的路径. 例如,当我设置默认值并运行which ruby​​时: =>/home/COM-COM/.rvm/rubies/ruby-2.5.1/bin/ruby 当我打开一个新的终端窗口并运行 which ru ..
发布时间:2021-07-14 18:48:18 其他开发

未初始化的常量 AppGenerator::Config 错误

我实际上是从 Ubuntu 13.10 升级到 Ubuntu 16.04 我的 rails 在以前的版本中运行良好.我正在删除 rvm 并从头开始重新安装.然而,当我尝试调用服务器时,我总是收到此错误 未初始化的常量 AppGenerator::Config你的意思?配置文件 我必须定义导轨路径吗? 解决方案 不知何故(我认为在安装 Redmine 之后)我的环境崩溃了. ..
发布时间:2021-07-14 18:48:15 其他开发

在 Ubuntu 12.04.1 LTS 上安装 ruby​​ 2.0.0-p247

我正在尝试在我的 ubuntu 机器上安装 ruby​​ 2.0,但我不断收到以下信息: SERVER_USER@SERVER_NAME:/var/www/FOLDER_NAME$ rvm 获得稳定 &&rvm 安装 ruby​​-2.0.0错误:未知的 ruby​​ 解释器版本:'2.0.0'将 Ruby 从源安装到:/usr/share/ruby-rvm/rubies/ruby-2.0.0- ..
发布时间:2021-07-14 18:48:12 其他开发

Textmate + RVM + Rake = Rake 不使用预期的 gem 环境

我正在使用: TextMate:版本 2.0-alpha.9511 rvm:1.25.15(稳定) 红宝石:版本 2.1.0p0 oh-my-zshell: 5.0.2 Mac OS X:10.9.1(小牛队) 我已经设置好可以使用的 rvm 和 textmate TM_RUBY=/Users//.rvm/bin/rvm-auto-ruby 问题: 当 ..
发布时间:2021-07-14 18:47:57 其他开发

RVM Ruby 安装问题

我正在尝试通过 RVM 安装 Ruby 1.9.3.但是,我不断收到附加图片中的错误. 我将不胜感激. 解决方案 您看到的不是错误,而是您应该阅读的内容,以了解您现在需要做什么来配置您的环境以安装 rubies. ..
发布时间:2021-07-14 18:47:54 其他开发

ruby 的已知版本 - rvm 列表已知

可能的重复: 删除 ruby​​ 版本 我正在尝试卸载单个版本的 ruby​​.此列表中的第二个: which -a ruby/Users/snowcrash/.rvm/rubies/ruby-1.9.2-p318/bin/ruby/Users/snowcrash/.rvm/bin/ruby 但是,当我跑步时: rvm 删除 我得到: 真的吗?移除所有?请参阅“rvm 列表已知" ..
发布时间:2021-07-14 18:47:51 其他开发

无法在 ruby​​ 2.3.1 上安装 rails gem

我正在尝试在 ruby​​ 2.3.1 上安装导轨. $ ruby​​ -v红宝石 2.3.1p112(2016-04-26 修订版 54768)[x86_64-linux] 安装了 Ruby. $ rvm -vrvm 1.26.11(最新)作者:Wayne E. Seguin ,Michal Papis [ ..
发布时间:2021-07-14 18:47:49 其他开发

使用特定版本的 ruby​​ 在 cron 上运行 gem

我们需要按 cron 计划运行某个 gem 应用程序,因此我们设置了一个专门的用户来运行此 gem. 我们目前使用的是 ruby​​ 1.9.2 [jobrunner@test-load] rvm 列表rvm红宝石ruby-1.8.7-p299 [ x86_64 ]ruby-1.9.2-p180 [ x86_64 ]=* ruby​​-1.9.2-p290 [x86_64]ruby-1.9 ..
发布时间:2021-07-14 18:47:45 其他开发

错误:安装 RVM 时出现修改器错误

我正在尝试运行 source/Users/alastair/.rvm/scripts/rvm,但继续: Bad : $ (") 中的修饰符. 问题出在哪里?如果有帮助,很乐意粘贴其他文件. 解决方案 在任何情况下,您是否都在运行不是 Bash 或 ZSH 的 shell?Bash >= 3.2.25 或 ZSH >= 4.3.10 是必需的. 您的问题看起来像您使用的是 ..
发布时间:2021-07-14 18:47:42 其他开发

在启动 rails webrick 服务器时报告错误

我有一个在 rails 2.3.2 上运行的应用程序,现在我将 Rails 版本升级到 3.0.3 在我尝试通过键入 rails server 来启动应用程序服务器之后 我得到了一个我应该传递给命令的参数列表.这表明服务器没有成功启动.但是,在哪里可以获得启动 rails 服务器时遇到的错误列表? 此外,我使用 RVM 来管理 Rails 版本.但是,即使更改了当前运行的rails ..
发布时间:2021-07-14 18:47:39 其他开发

Vagrant - 未安装 Rails

我最近不得不销毁并重新创建我的 Vagrant 实例.现在我无法运行任何 rails 命令,因为它说未安装 Rails.当我这样做 流浪 我收到以下错误 default:/tmp/vagrant-shell: line 1:/home/vagrant/.rvm/scripts/rvm: 没有那个文件或目录 以下 SSH 命令以非零退出状态响应.Vagrant 假设这意味着命令失败! ..
发布时间:2021-07-14 18:47:36 其他开发

为什么“rvm 使用"命令需要/建议登录 shell?

使用 RVM 的默认安装和非登录 shell,执行 rvm use 会产生: RVM 不是函数,选择带有“rvm use ..."的红宝石将不起作用.您需要更改终端模拟器首选项以允许登录 shell.有时需要使用 `/bin/bash --login` 作为命令.请访问 https://rvm.io/integration/gnome-terminal/获取示例. 出现此警告的原因是在安装过程 ..
发布时间:2021-07-14 18:47:33 其他开发

Ubuntu 上的 RVM 问题

我在尝试在 Ubuntu 9.10 上安装 RVM 时遇到了很多问题.这是我尝试过的步骤: 安装 ruby​​(通过 ruby​​ 站点,无包管理器) 下载 rvm 安装 rvm(编辑到 .bashrc) 使用 rvm 安装 ruby​​ 版本 &宝石 是否有任何我似乎遗漏的关键步骤? 解决方案 确保选择了一个已安装的 ruby​​(--default 部分告诉 rvm ..
发布时间:2021-07-14 18:47:30 其他开发

Ruby 1.9.2 未安装在 OSX 上?

我有 Xcode 3.2.1 我已经安装了 Git 和 RVM 我已经安装了 Ruby 1.9.2,它已 100% 安装 我运行 ruby -v 但没有看到 ruby 1.9.2p0 (2010-08-18 修订版 29036) [x86_64-darwin10.4.0] 我明白了 ruby 1.8.7 (2009-06-12 patchlevel 174) [universal- ..
发布时间:2021-07-14 18:47:26 其他开发