android-support-library相关内容

TabLayout设置每个选项卡的间距或页边距

我要在每个选项卡之间设置边距。就像在PagerTabZone中一样,它有setTextSpacing(Int ExtSpacing)来在制表符之间设置文本间距。TabLayout可以做到这一点吗? 推荐答案 也与这个问题斗争了一段时间,在这个帖子上找到了解决方案:Android Design Support Library TabLayout using custom tabs lay ..

枚举与Android@Intdef-哪一个优化得更好

我知道,在将常量与枚举进行比较时,常量占用的空间更少,而且可以是原始的。我正在研究Android中的@Intdef annotation,有人能告诉我使用@Intdef比使用枚举存储更好吗?在Android中,是否建议将枚举放在一边,尽可能使用@intdef向前推进?我怀疑@Intdef可以做多态性吗? 来自Android文档关于内存的overhead: 枚举通常需要的内存是静态常量的 ..
发布时间:2022-04-16 20:36:27 移动开发

想使用ViewPager,无法识别android.support.*?

编辑对不起所有的图片.我试图让你知道我在哪里. 我正在尝试获取 ViewPager 在我的应用程序上工作,但它无法识别 Support Library. 我正在为 SDK 版本 10 编写代码.这是我的 SDK Manager 的屏幕截图: 安装 Android 支持库 和最新的 Tools 后,我去了 Help >> Check for Updates.运行此之后,我收到如下所 ..
发布时间:2022-01-19 20:06:25 移动开发

Fragment 和 FragmentStatePagerAdapter 中带有 ViewPager 的片段导致异常(带有完整示例)

我有一个带有 ViewPager 的简单片段. 我正在使用最新的支持库 v4 rev18! 如果我第一次显示子片段,一切正常,如果我返回并再次显示,应用程序崩溃并出现以下异常: 我有一个完整的示例,它显示了何时发生以下异常: java.lang.NullPointerException在 android.support.v4.app.FragmentManagerImpl.ge ..

在没有支持库的情况下使用 FragmentStatePagerAdapter

我想知道是否可以在没有支持库的情况下使用 FragmentStatePagerAdapter 类或其等效类? 我知道如何使用本机片段来代替支持库中的片段,并且许多其他类也有类似的等价物,但我找不到应该使用什么来代替这个类. 我基本上想扩展它以便像这样在我的适配器中使用它 公共类 ImageAdapter 扩展 FragmentStatePagerAdapter {... 解决方案 ..

仅在第二次导航到 Fragment 时导致 java.IllegalStateException 错误,No Activity

我遇到了一个非常令人费解的错误,我什至不知道如何开始解决. 我有一个带有一个活动的简单应用程序,视图是用片段实现的.其中一个片段内部有一个 ViewPager;所以我决定我想使用 v4 支持库的 getChildFragmentManager 类.我还必须使用 ActionBarSherlock,这会导致问题,因为它没有随 v4 库的 v11 一起提供. 我通过将 ABS 中的 v4 ..

上一页和下一页可见的Android ViewPager?

我目前正在构建一个水平视频库. 我想制作这样的东西,只有一个视频居中,上一个和下一个视频的一部分: 我首先选择了 Gallery,但它的局限性让我看了为了别的东西.我想显示一个页面指示器,但使用 Gallery 很难实现. 第二种选择是选择 来自 Android 兼容性库的 ViewPager.我找到了一种在其上实现 页面指示符 的方法.但是现在,如何部分显示左右页面呢? ..

如何使用嵌套片段(Android 4.2)在 ViewPager 中添加片段

我有一个 ViewPager,其中包含三个 Fragments,每个片段显示一个 List(或 Grid). 在新的 Android API 级别 17(Jelly Bean 4.2)中,其中一项功能是 嵌套片段.新的功能描述说: 如果您使用 ViewPager 创建左右滑动的片段占用大部分屏幕空间,您现在可以插入片段进入每个片段页面. 所以,如果我理解正确,现在我可以在里面创建 ..

NotificationCompat.Builder(getApplicationContext(), CHANNEL_ID) 不适用于 Oreo Firebase 通知

我正在尝试在 Oreo 版本 中使用 Firebase 显示通知,所以当我得到解决方案时它没有显示 NotificationCompat.Builder(this, CHANNEL_ID) 但它向我展示了这样 解决方案 NotificationCompat.Builder(上下文上下文) 此构造函数在 API 级别 26.1.0 中已弃用. 使用 NotificationComp ..

添加的 EditText 不是 TextInputEditText.请改用该课程

我在 TextInputLayout 中使用 EditText,但是在将支持库升级到 23.2.0 后,我在 logcat 中收到此警告,这两者有什么区别一个常规的 EditText 和一个 TextInputEditText?我似乎找不到任何文档. 解决方案 我也在想这个,Daniel Wilson 聚集文档,但对于未经训练的人来说,这并不意味着什么.这就是它的全部内容: "提取模式" ..

Android Studio 突然开始显示无法解析 com.android.support...25.0.0 错误信息,我的所有 java 文件现在都出错了?

我的项目运行良好,但直到有一天,我将项目上传到 github.我不知道这个问题是否与此有关,但是今天当我编译我的 android studio 项目时,它开始向我显示这 4 个可怕的错误.我已经尝试了大部分谷歌结果,但没有任何帮助! 错误:无法解决:com.android.support:cardview-v7:25.0.0 错误:无法解决:com.android.support:cust ..