grails-plugin相关内容

在jar文件中创建grails二进制插件结果,该文件包含所有带有注释的groovy文件

我正在使用grails 2.3.0插件中的grails发布插件(3.0.1)来构建 的二进制插件 maven-deploy --binary 我还在我的Plugins Descriptor Groovy脚本中设置了def packaging = "binary". 当我用jd-gui检查创建的jar文件时,我可以看到它包含我的*.groovy源,并且在*.class文件之间有注释. ..
发布时间:2020-05-07 21:49:40 Java开发

grails:无需页面刷新即可上传图片

我已经通过Ajax(在Grails中)对堆栈和Google for Image上传进行了一些研究,因此发现了一些旧链接,因此我决定问你们:"是否有任何方法可以上传我的用户图片使用Ajax "?我找到了一个Grails插件插件链接,但是该插件的文档不足.我想使用该插件(如我所说,由于缺少该插件的良好文档,看来我很难实现它)或请告诉我一些替代选项(如果可用). 解决方案 尝试一下..,. ..
发布时间:2019-11-18 11:18:51 前端开发

使用圣杯石英插件的多个调度程序

我使用grails quartz插件在我们的应用程序中实施日程安排。我用QuartzConfig.groovy props创建了一个调度器,这是一个集群调度器。我希望在同一个应用程序中有一个调度程序用于非集群调度。 如何使用相同的grails quartz插件实现此目的。 解决方案 我在resources.groovy中创建一个新的调度器bean: newQuartzSche ..
发布时间:2018-05-24 19:29:32 其他开发

Grails 2.1.0无法安装webflow插件

我正在运行Grails 2.1.0,我无法安装webflow插件: $ grails install-plugin webflow |插件已安装。 $ grails |配置classpath :: problems摘要:: ::::警告 找不到模块:org.springframework.webflow#org.springframework.webflow; ..
发布时间:2018-05-24 19:28:45 其他开发

没有找到TestDataConfig.groovy,build-test-data插件在没有配置文件的情况下进行处理

TestDataConfig.groovy未找到,build-test-data插件在没有配置文件的情况下执行 它在集成测试中很像魅力,但不是单元测试的一部分。我的意思是,'build'插件在单元测试中工作,但'TestDataConfig'没有填充默认值。 谢谢 解决方案 首先,您应该在您的BuildConfig.groovy test“中验证build-test-da ..
发布时间:2018-05-24 19:27:46 其他开发

跨Grails域类进行复杂搜索

我希望能够对grails对象进行复杂的搜索。这是目前使用我网站上的存储过程实现的,这些存储过程构建了一个SQL查询并解析了所有这些结果。 类似可搜索插件的东西是否允许我简化这个任务?我的猜测不是,因为它主要是在做基于文本的搜索。存储过程非常复杂,难以改变。我们的用户是员工,这些查询必须与大量的工作经验,他们的工作对象,他们拥有的技能等有关。员工域对象应该包含一些包含技能的角色列表。这个角色将 ..
发布时间:2018-05-24 19:25:39 其他开发

在grails 2.2.4 spring security core 2.0中配置ldap?

我目前正在努力将我的应用程序与公司ldap集成。虽然我能够使应用程序实际上检查ldap上的用户进行身份验证,但用户无法克服弹簧安全ROLES配置。我得到: “拒绝 抱歉,您无权查看此页面。” 每次我尝试输入带有@Secured(['ROLE_USER'])的页面就可以了。我想知道如何在LDAP上添加每个用户以拥有ROLE_USER,以便他能够充分使用应用程序。 我的LDAP配置非常简单 ..
发布时间:2018-05-24 19:25:00 其他开发

为自定义Grails插件创建GroupID和ArtifactID

我正在编写自己的Grails插件。 当我打包时,我看到一个pom.xml和plugin.xml被生成。其中 groupId 和 artifactId 是 org.grails.plugins 和 plugin-config 。 我想指定这些应该是什么,以便我的插件结束在美工的正确位置。 我该怎么做? 谢谢。 解决方案 这是插件的默认设置 groupId 的作用。对于所有 ..
发布时间:2018-05-24 19:20:59 其他开发

如何从zip安装Grails 2.4.4插件?

我需要2.4.4中的grails-spring-security-ldap插件。然而,最新的Maven发布的插件不适用于2.4.X,但已提交到git repo( 我已经下载了代码并成功打包了一个zip文件。我还读到,您不能再在项目/ lib目录中放置压缩文件,并希望在将其添加到BuildConfig.groovy后找到它。所以,我安装到我的本地m2目录中: grails maven- ..
发布时间:2018-05-24 19:20:27 其他开发

Grails 2.2.1应用程序无法解决依赖关系

我遇到了在新的mbp上设置现有grails(2.2.1)项目时遇到的问题。每当我尝试运行任何grails命令时,都会收到依赖项解析错误。看起来,它不能解决像下面这样的编译阶段标记的任何grails插件。 compile“:cache:1.0。 0“ 我查看了org.grails.plugins存储库以确保插件存在,他们都似乎在那里。我不能为了我的生活找出为什么它不能解决这些 ..
发布时间:2018-05-24 19:20:12 其他开发

Mongodb的Grails聚合框架1.3.7

如何在Grails 1.3.7中使用Aggregation框架。目前我无法迁移到新版本的grails。我已经尝试过grails mongodb plugin 1.0.0.GA,但它使用的是旧的java驱动程序和gmongo库。我也尝试在build-config.groovy中添加新libs / jar的依赖项,但它仍然在运行时给我提供了集合方法的错误。任何帮助的高度赞赏。 解决方案 在您的 ..
发布时间:2018-05-24 19:20:10 其他开发

Grails:添加或修改Grails插件

有一个插件,我想添加功能,因为它不太实用(以一种实用的方式)。你是否创建了一个新的插件,或者它是否允许更新现有插件? 您应该可以添加到现有的一。理想情况下,插件网站上的插件页面( http://grails.org/plugins/ )应该有一个链接到通常在颠覆或混帐的来源。如果它在Subversion或私有GIT仓库中,您可能需要通过电子邮件发送grails开发人员列表( http://grai ..
发布时间:2018-05-24 19:19:46 其他开发

在Grails Spring应用程序中获取LDAP属性memberof

我被困在一个非常愚蠢的问题中,试图使用spring-security-core和spring-security-ldap插件在Grails应用程序(书店)中实现基于LDAP角色的认证/授权。我创建了一个自定义的UserDetailsContextMapper并试图将我的LDAP角色映射到应用程序角色。但是, memberof 属性永远不会返回到属性中。 UserDetails mapUse ..

Grails从现有的数据库中读取

我想从另一个项目中已经存在的数据库中提取数据到我的Grails项目中并列出数据。我应该为现有的数据库创建一个域控制器吗?我知道如何创建域控制器并使用数据迁移插件来更新数据库,但我读过的书中没有任何关于如何从现有数据库设置和读取的信息。我为我的数据库使用MySQL。 使用Reverse Engineer插件从现有数据库创建域类: org / plugin / db-reverse-engineer“ ..

如何在Grails 3.0.4中配置插件的安装?

我将一个应用程序从Grails 2.4.2移植到Grails 3.0.4,我遇到了一些以前安装的插件的问题。特别是在GSP页面中引用的一个。这个特定的插件叫做google-visualizer,我在这里找到了一些信息: https://github.com/bmuschko/grails-google-visualization/blob/master/grails-app/ views / ..
发布时间:2018-05-24 19:11:11 其他开发

在Grails中加载UrlMappingsPlugin时出错

当加载插件管理器时出错:无法创建类 的新实例[org.codehaus.groovy.grails.plugins.web.mapping.UrlMappingsGrailsPlugin]! (使用--stacktrace查看完整跟踪) Grails 2.4.3版本 解决方案 这个问题的解决方案是添加tomcat插件(不知道为什么): 将此添加到BuildConfig.gro ..
发布时间:2018-05-24 19:10:56 其他开发