分类:Eclipse

Eclipse

JSEclipse替代品在Ganymede

我在Ganymede中遇到了很多JSEclipse的问题,但是我没有多少运气找到与Ganymede(eclipse 3.4)兼容的替代方案。 解决方案 Spket 是一个非常好的JS插件,可与Ganymede一起工作。它提供的不仅仅是突出显示(例如,大纲视图和跳转到函数定义的能力),但仍然非常轻量级。 对各种JS的更详细的讨论适用于Eclipse的插件可从此获得 Eclipse中的J

IT屋 2017/8/1 23:10:15 喜欢

Eclipse

用于Bluemix的IBM Eclipse Tools

新的ibm bluemix。在eclipse上开发一个应用程序,并使用IBM Eclipse Tools for Bluemix和云代码开发的步骤。 解决方案 首先,您可以按照以下说明安装Bluemix的IBM Eclipse Tools https: //marketplace.eclipse.org/content/ibm-eclipse-tools-bluemix 其次,您可以

IT屋 2017/8/1 23:06:33 喜欢

Eclipse

插件启动时访问工作台

我想在插件开始时访问 IWorkbench ,以附加 IPartListener 。 最简单的解决方案是在插件的 start()方法中添加侦听器: p> public class MyPlugin extends AbstractUIPlugin { private IPartListener partListener = new MyPartListener(); p

IT屋 2017/8/1 23:06:15 喜欢

Eclipse

实例化eclipse插件时的ClassNotFoundException

我开发了一个eclipse插件,我试图将它安装在另一个eclipse的实例上。 当我作为eclipse应用程序运行/调试我的插件时,一切正常。只有在我通过我创建的更新站点安装插件之后,才会出现此问题。 我创建了一个非常简单的更新站点,其中包含一个包含我的插件的单一功能。使用更新站点安装后,我可以在eclipse安装目录下的插件目录中看到我的插件,它正确地包含了应该在那里的所有数据(我想)。

IT屋 2017/8/1 23:05:37 喜欢

Eclipse

以编程方式开始/停止片段

我想在OSGI中实现一个功能切换,这意味着我想以编程方式启动和停止软件包。 对于非常容易的插件: Bundle plugin = // ... plugin.start(); plugin.stop(); 对于片段,这不是那么容易。停止不起作用,如果我使用 uninstall()片段已经不好了,我无法再安装,因为我不知道正确的位置 BundleContext

IT屋 2017/8/1 23:05:25 喜欢

Eclipse

尝试访问安全API时,Blackberry Mobile应用程序会收到错误?

我开发了一个使用Eclipse的Blackberry应用程序。应用程序在模拟器中正常工作。通过使用黑莓桌面软件,我测试了黑莓手机的应用程序,它的工作正常;但是当我使用Progressbar屏幕时,我收到一个错误,如“启动Applicationname:Module”ApplicationName尝试访问安全的API。“ 避免这个错误? 解决方案 你需要签署你的申请。阅读这篇文章。

IT屋 2017/8/1 23:04:59 喜欢

Eclipse

从eclipse插件项目运行program.exe

我正在写一个eclipse插件巫婆运行程序。我已经将program.exe添加到插件jar文件中。如何执行这个程序? public class Handler extends AbstractHandler { public Object execute(ExecutionEvent event)throws ExecutionException { Runtime.getRuntim

IT屋 2017/8/1 23:04:46 喜欢

Eclipse

虚拟TableViewer排序导致选择问题

我们的应用程序是RCP应用程序,需要显示数千项目的表格。因此,我们在 TableViewer 中使用 SWT.VIRTUAL 。 我们遇到以下问题: 我们的 TableViewer 支持排序和过滤。当我们使用虚拟表视图时,更改选择不会保留当前所选项,而是当前选择的行。这将导致另一项被选中。 例如:如果用户选择第5行出现的“A”,执行排序,则在排序后排列第5行的项目而不是“A”项。

IT屋 2017/8/1 23:04:32 喜欢

Eclipse

Maven Tycho插件和Eclipse Babel

如何使用 Maven Tycho Plugin 与 Eclipse Babel ?我没有找到有关它的信息。 解决方案 现在我找到解决方案。因为这需要在pom文件中简单添加babel存储库。例如: < repository> < id> p2-babel< / id> < layout> p2< / layout> < url> http://download.eclipse.o

IT屋 2017/8/1 23:04:19 喜欢