如何在同一设备上为不同的项目使用两个版本的颤动? [英] How to use two version of flutter on same device for different projects?

查看:11
本文介绍了如何在同一设备上为不同的项目使用两个版本的颤动?的处理方法,对大家解决问题具有一定的参考价值,需要的朋友们下面随着小编来一起学习吧!

问题描述

我有一个稳定的颤动频道SDK,位于c:Fighter。在系统环境变量中设置为颤振的默认路径。

在IntelliJ中为我们的客户创建新的颤动项目时,我使用此路径c:Ffltter。

我还在c:fltter_master下载了颤动主频道,我需要在另一个项目中使用这个颤动SDK(主)。

如何才能在同一设备上针对不同的项目正确地使用两个工作颤动版本,而不需要每次都使用系统环境变量?

推荐答案

如果您使用VSCode,则可以为每个工作区指定颤动SDK。您需要:

  1. 将颤振回放复制到新文件夹:
mkdir ~/flutter_dev
cd ~/flutter_dev
git clone https://github.com/flutter/flutter.git .
  1. 创建.vscode/settings.json,内容如下:
{
  "dart.flutterSdkPath": "/Users/youruser/flutter_dev"
}
  1. 重新启动VSCode,即可开始。

Dart Code - Quickly Switching Between SDK Versions中查看更多信息

这篇关于如何在同一设备上为不同的项目使用两个版本的颤动?的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持IT屋!

查看全文
登录 关闭
扫码关注1秒登录
发送“验证码”获取 | 15天全站免登陆