eclipse-kepler相关内容

ANTLR4 解析器,未创建访问者

我是 ANTLR 的新手,并尝试在 ANTLR4 中编写语法,而无需事先刷过以前的版本.我正在关注“权威 ANTLR 4 参考"一书.我使用 Eclipse 并安装了 此处 中给出的 ANTLR4 IDE.我在 Expr.g4 中写了以下语法: 语法表达式;进口通用;选项{语言 = Java;}编:统计+;统计:expr NEWLINE|ID '=' expr NEWLINE|新队;expr: ..
发布时间:2021-11-11 04:03:05 其他开发

Ant 在 Eclipse Kepler 中不起作用(Java 虚拟机启动器 - 发生了 Java 异常)

我最近升级到 Eclipse Kepler,但遇到了 Ant 问题.我收到 Java 虚拟机启动器 - 无论我在构建文件中选择哪个目标,都发生了 Java 异常错误. 我尝试重新安装 JDK,但仍然出现错误.我正在运行 JDK 的 7u25 版本.我的 JAVA_HOME 环境变量设置为 C:\Progra~1\Java\jdk1.7.0_25,所以我不认为这是问题所在.还有什么可能导致问题 ..
发布时间:2021-11-11 02:54:41 其他开发

龙目岛不适用于eclipse kepler

我正在使用eclipse kepler,不幸的是,lombok无法正常工作.蚀崩溃了. 如何解决这个问题? 顺便说一句,我不能更新我当前的eclipse kepler版本. 您正在使用哪个版本的Lombok? 这是日志; java.lang.NoClassDefFoundError:无法初始化类lombok.launch.PatchFixesHider $ Transf ..
发布时间:2021-05-30 20:59:35 其他开发

无法安装新软件/无法检查更新

我正在尝试在桌面上安装subclipse,以便可以使用subversion. 当我在学校里用笔记本电脑进行安装时,安装效果很好,我能够更新并提交该Subversion,但是当我在家时,我尝试进行更新,但没有任何效果.然后,我尝试在桌面上安装subclipse插件,但没有成功. 当我转到“帮助">“安装新软件">“与开普勒一起使用- http://download.eclipse.org ..
发布时间:2021-05-03 19:43:41 其他开发

在Eclipse Kepler中为Maven Web App项目创建新的servlet

我创建了简单的Maven Web应用程序项目.创建后,没有"src/main/java"和"src/test/java"文件夹,只有"src/main/resources"文件夹.我添加了这两个文件夹并更新了Maven项目. 然后,我在'src/main/java'中添加了一些软件包,并尝试通过右键单击软件包元素来添加servlet 但是当我开始添加servlet名称时,eclipse ..
发布时间:2021-05-03 19:39:51 其他开发

如何实现“另存为”。我们部分的功能

我正在创建E4 RCP应用程序,因为我只有一部分。我想为我的部件实现“另存为”功能,因为它是为编辑器实现的(例如:Java文件编辑器)。 要求: 当用户单击我的零件时,应启用“另存为”选项。 当用户单击“另存为”时选项应该运行我的代码,以便我可以做我想做的事。 所以我的问题是我应该怎么做,是吗必须实现任何扩展点或其他任何扩展点。 ? 解决方案 在纯e4应用程序中,没有对 ..
发布时间:2020-10-27 19:57:55 其他开发

Eclipse RCP-在编辑器文件夹中打开视图

是否可以在编辑器文件夹堆栈中添加占位符? 我目前可以将视图(拖动-拖放)移动到编辑器旁边,但是我希望直接在此处打开它们。 解决方案 如果使用的是eclipse 3.x,则不可能。应该可以使用4.x(因为Eclipse 4不再具有编辑器区域,必须为透视图定义该区域,以便您也可以将编辑器放入ViewStack中。)。您可能会在 Vogella的文章中找到有用的东西。 ..
发布时间:2020-10-27 19:55:05 其他开发

Eclipse 4.3 EE Facet JPA 2.0构建错误

我正在尝试Eclipse Kepler 4.3 EE 在旧工作区中打开它之后,我的项目开始出现构建错误: 此项目具有JPA方面,但是无法创建JPA项目。有关更多详细信息,请参见错误日志。 这是详细信息: eclipse.buildId = 4.3.0.I20130605-2000 java.version = 1.7.0_21 java.vendor ..
发布时间:2020-10-27 18:55:49 其他开发

Eclipse Kepler无法安装更新

下载更新后,它显示无法安装更新的错误。 在卸载 会话上下文时发生错误是:(profile = epp.package.cpp,phase = org.eclipse.equinox.internal.p2.engine.phases.Uninstall,opernd = [R] org.eclipse.rcp.configuration_root.win32.win32.x86_64 1. ..
发布时间:2020-10-27 18:32:08 其他开发

Eclipse Juno和Eclipse Kepler

每个Eclipse版本(Juno和Kepler)的优缺点是什么?哪个版本更稳定? 解决方案 每个eclipse版本都有一些错误修复,新功能更新了API等。 p> 您可以查看每个发行版的新闻和值得注意的部分,以了解当前发行版与先前版本的不同之处。 此处。 比较此处和此处。 请注意,开普勒功能版本更高(或更新),表示新的Eclipse版本中的错误修复或新功能。 有关详细 ..
发布时间:2020-10-27 05:41:43 其他开发

如何在Eclipse Juno / Kepler / Luna CDT中启用C ++ 11?

编辑:事实证明,这并不是特定于Eclipse Kepler。我必须对Eclipse Juno使用相同的过程。问题在于,其他帖子中似乎缺少回答这一问题的步骤。 我正在使用Eclipse Kepler for C ++,并且正在尝试使用C + +11并得到错误。编译时出现错误 错误:在C ++ 98模式下不允许基于范围的for循环 我遵循了帖子中的说明 Eclipse CDT ..
发布时间:2020-10-27 05:28:35 其他开发

eclipse:未警告未使用的私有方法

关于日食开普勒SR1 嗨, 我记得有一个未使用的私有方法正在收到警告 我不知道是否更改为切换到开普勒(或先前版本)还是项目设置,因为我正在研究共享月蚀设置的新项目。 我什至在eclipse编译器设置中找不到该设置。 解决方案 转到“打包资源管理器”上的项目,右键单击它,然后选择“属性”。然后在属性“ Java编译器”,“错误/警告”中。选中“启用项目特定设置”复选框 ..
发布时间:2020-10-07 00:05:46 其他开发

蚂蚁在Eclipse Kepler中不起作用(Java虚拟机启动器-发生Java异常)

我最近升级到Eclipse Kepler,并且在Ant方面遇到问题.我正在获取Java虚拟机启动器-无论我在构建文件中选择了哪个目标,都发生了Java异常错误. 我尝试重新安装JDK,但仍然出现错误.我正在运行Ju的7u25版本.我将我的JAVA_HOME环境变量设置为C:\Progra~1\Java\jdk1.7.0_25,所以我不认为这是问题所在.还有什么可能导致该问题? 编辑:我 ..
发布时间:2020-09-02 21:27:51 其他开发

Eclipse菜单在Ubuntu-13.10中变形

我最近在15英寸屏幕的Lenovo intel core2 duo 32位笔记本电脑上安装了Ubuntu 13.10.几天前,我从Eclipse网站下载了eclipse-standard-kepler-SR1-linux-gtk.tar.gz.但是在开始日食之后,我看到菜单变形了. 您可以在此处参考视频: http://youtu.be/fcBHLAlFj4Y 解决方案 您可以尝试以下命令 ..
发布时间:2020-07-12 05:54:11 其他开发

Eclipse Kepler RCP主要工具栏操作

Google 是我最好的朋友,但是我得到的信息过于分散且不清楚。没有简明的教程来描述我的需求。 我想在我的RCP应用程序的主工具栏中添加操作,但是我需要对每种方法进行详尽的解释。但是,由于这是StackOverflow,所以我会写下所有问题,并希望答案能解决。 添加动作的新和旧哪种方式?通过 ActionBarAdvisor 或通过 plugin.xml ? 可以使用 plugi ..
发布时间:2020-06-01 00:44:47 其他开发

如何在Eclipse Kepler中卸载M2e

我刚刚下载了eclipse kelper,发现已经安装了m2e和m2e-wtp插件,而新的m2e插件没有生命周期的“软件包",我该如何卸载? ================================================ == http://m2eclipse.sonatype.org/sites/m2e 这是我在eclipse juno中使用的更新站点(现在似乎出现404 ..
发布时间:2020-05-04 08:42:28 其他开发

龙目岛+ Eclipse开普勒

因此,在将Eclipse从Helios更新到Kepler之后,我发现我的Lombok依赖项目充满了错误,因为eclipse看不到@Getter和东西所添加的方法,因此我重新安装了Lombok,但是Eclipse崩溃了或只是没有看到方法,取决于我如何运行它.如果我从Windows资源管理器中的eclipse.exe中运行了该程序,则它开始时不会出现lombok,并且如果我在运行对话框中将其键入,则会 ..
发布时间:2020-05-04 03:44:16 其他开发

开普勒生命周期未涵盖的aspectj-maven-plugin

我刚刚下载了OEPE(Kepler)并安装了m2e和m2e-wtp连接器. 我发现在以下路径下:首选项-> Maven->生命周期映射->打开工作区生命周期映射数据,有一个预配置的xml文件,其中说maven应当忽略AspectJ的编译目标,并且我认为这就是AspectJ运行时库是没有添加到项目中,因此该项目不会被eclipse识别为AspectJ项目. ..
发布时间:2020-04-30 11:02:03 其他开发

重置Eclipse透视图布局

我刚刚从Eclipse Juno更新到开普勒. Eclipse透视图布局发生了什么,如何恢复它以填充整个窗口? 解决方案 从图像上看,您确实确实具有最小化的透视图堆栈...它是图像顶部最右边的工具栏,仅包含用于Java和调试的观点.如果单击其“恢复"按钮,则实际透视图将重新出现. 看起来像是您已经打开并最大化了“欢迎"(简介)屏幕(因此最小化了透视图堆栈).如果单击右上方工具栏中的选 ..
发布时间:2020-04-30 07:44:28 其他开发