使用OpenJDK 11生成Apache NetBeans 11.1版时出现错误 [英] Apache Netbeans version 11.1 building error with OpenJDK 11

查看:49
本文介绍了使用OpenJDK 11生成Apache NetBeans 11.1版时出现错误的处理方法,对大家解决问题具有一定的参考价值,需要的朋友们下面随着小编来一起学习吧!

问题描述

我有一个使用JDK 8和NB 8.2创建的项目,我想将此项目迁移到使用OpenJDK 11的NB 11.1。

环境为:使用OpenJDK 11.0.2的Windows 10上的NB 11.1(全新安装)。

我将所有的源代码和库(.jars)复制到一个新项目NB 11/OpenJDK 11中,并解决了从JDK 8到OpenJDK 11的(几个)问题,但在构建项目时,我收到了这样的错误:

error : option -Xbootclasspath/P: not allowed with target 11

我认为这是与Java版本相关的问题,所以在项目的属性面板中,我将源代码/二进制格式从JDK 11更改为JDK 8,一切正常!

但是...我如何才能正确地解决这个问题(使用源代码JDK 11格式)?我记得在NB8.2中,我对从JDK 7到JDK 8的一个项目做了同样的操作。

推荐答案

这是NetBeans错误。请参见NETBEANS-2452 -Xbootclasspath/p is no longer a supported option。阅读该错误报告的活动下的注释选项卡,了解一些可能的解决方法。

另请参阅此堆栈溢出问题,该问题与您的问题不完全相同,但很接近:error: option -Xbootclasspath/p: not allowed with target 12 (Netbeans 11.0)

这篇关于使用OpenJDK 11生成Apache NetBeans 11.1版时出现错误的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持IT屋!

查看全文
登录 关闭
扫码关注1秒登录
发送“验证码”获取 | 15天全站免登陆