canopy相关内容

AttributeError: 'module' 对象没有属性 'cbook'

我正在尝试运行一个简单的代码,并且在我的 Canopy 中安装了 matplotlib 和 numpy 的所有依赖项.我仍然收到错误. 导入 cv2将 numpy 导入为 np导入 matplotlib.pyplot 作为 pltx = cv2.imread('jay.jpg')plt.imshow(x, cmap = 'gray', 插值 = 'bicubic')plt.xticks([]) ..
发布时间:2021-11-30 15:28:22 Python

在 MacOS 10.9.2 上的 Enthought Canopy 中运行 winpdb

我在 MacOS 10.9.2 上安装了 Enthought Canopy 1.4.尝试运行 winpdb 调试器会导致以下消息: 这个程序需要访问屏幕.请使用 Python 的框架构建运行,并且仅当您登录到 Mac 的主显示屏. 作为一种解决方法,我尝试创建一个 shell 脚本 run.sh,其中包含 PYVER=2.7PYTHON=/System/Library/Frameworks/ ..
发布时间:2021-09-29 19:12:08 其他开发

在 canopy 中自定义语法高亮

我刚刚在全新(干净)安装的 Mac OS X Mountain Lion 中安装了 Enthought Canopy.到目前为止,它似乎运行稳定且快速.我唯一的问题是我想自定义编辑器和控制台的语法突出显示.没有偏好允许我觉得很奇怪,因为嵌入式编辑器只是 Editra,一个高度可定制的编辑器.我想: 编辑器.由于我之前使用过 Editra,我可以将旧样式文件 (.ess) 放在哪里以突出显示语 ..
发布时间:2021-09-03 20:48:39 其他开发

pyinstaller 错误:找不到 scipy(没有名为 _ufuncs_cxx 的模块)

我正在使用 pyinstaller 将 python 脚本转换为 Ubuntu (14.04) 中的二进制文件.我使用 Canopy (Enthought) 来管理所有的 python 库. 代码使用了 networkx、numpy 和 scipy.这是我的规范文件: # -*- 模式:python -*-a = Analysis(['main_test.py'],pathex=['/ho ..
发布时间:2021-07-16 20:53:45 其他开发

带有深思熟虑的树冠的 scipy

我正在评估 Enthought 包.我安装了 32 位机盖(从 https://www.enthought.com/downloads/ 下载)在Ubuntu. $ sudo bash canopy-1.0.1-rh5-32.sh 经过测试,我在 /usr/local/Canopy/appdata/canopy-1.0.0.1160.rh5-x86/lib/python2.7/site-pac ..
发布时间:2021-07-16 20:41:57 其他开发

sklearn OMP:拟合模型时出现错误 #15

我最近卸载了一个运行良好的 Enthought Canopy 32 位副本并安装了 Canopy 1.1.0 版(64 位).当我尝试使用 sklearn 来拟合模型时,我的内核崩溃了,我得到以下信息错误: 内核(用户 Python 环境)已终止,错误代码为 3.这可能是由于您的代码或内核本身存在错误.从内核进程捕获的输出如下所示.OMP:错误 #15:正在初始化 libiomp5md.dll, ..
发布时间:2021-07-16 20:01:24 其他开发

Enthought Canopy 中的 Python 3

如何在 Canopy Enthought 中使用 Python 3?它在底部有选择 Python 3 的选项,但这在我们使用时不会改变任何东西: print(sys.version)2.7.3 |32 位 |(默认,2013 年 3 月 25 日,15:38:39)[MSC v.1500 32 位(英特尔)] 解决方案 Enthought 工程师回答说,目前无法在 Canopy 中使用 Py ..
发布时间:2021-06-28 19:19:06 其他开发

删除变量不会从 RAM 内存中擦除其内存

我在地球科学应用中广泛使用 Python (Canopy).因为我的应用程序是内存消耗,我试图找到方法来擦除我在我的程序中不再需要的变量,我尝试使用 del 命令来擦除变量内存,但我发现 Canopy 使用的空间仍然是相同的.关于如何从内存中完全擦除变量的任何想法.谢谢 解决方案 您无法在 Python 中手动从内存中清除对象! Python 垃圾收集器 (GC) 将自动释放不再具有 ..
发布时间:2021-06-26 18:47:43 其他开发

让 PySide Hello App 在 Canopy 下运行

一位 Canopy 用户在这里学习 PySide.当我运行下面的演示代码时,QApplication 抱怨事件循环已经在运行.' 导入系统从 PySide.QtCore 导入 *从 PySide.QtGui 导入 *# 创建一个 Qt 应用程序#app = QApplication(sys.argv) #QApplication 抱怨一个实例已经存在app = QApplication.inst ..
发布时间:2021-06-24 20:27:35 其他开发

如何将 Pyqt 与 Enthought Canopy 一起使用

我安装了 EPD,并且正在试用 Canopy(Windows 7 64 位,学术许可).当我第一次启动 Canopy 时,什么也没发生(没有 GUI,没有错误消息),我意识到这是因为我将 QT_API 设置为 pyqt.将 qt_api 更改为 pyside 允许我启动 Canopy.完成此操作后,我检查了是否通过 Canopy 包管理器安装了 pyqt.但是 Canopy 拒绝从 QT_API ..
发布时间:2021-06-24 19:27:38 其他开发

py2exe 因导入熊猫而失败

我有一个 python 脚本,我想使用 py2exe 将其制作成可执行文件.当我尝试导入熊猫时它失败了(这就是我在示例失败脚本中所拥有的所有内容): 导入熊猫 回溯看起来像: File "c:\users\***\appdata\local\enthought\canopy\user\lib\site_packages\py2exe\mf.py", line 724, in import_h ..
发布时间:2021-06-23 19:26:05 其他开发

“天篷"的展示在命令行上

我有一个基本的终端问题.我刚刚在 Snow Leopard 上安装了 enthought 的 Canopy for Python,并且(Canopy 64 位)在我在命令行上工作时不断显示. 例如:(Canopy 64bit) Macbook~[用户名]$ 我尝试编辑我的 bashrc 文件,但无济于事. bashrc 目前有这个: # 用于交互式 bash(1) shell ..
发布时间:2021-06-13 19:13:40 其他开发

得到“libatk-1.0.so.0:未定义符号";当我在 Ubuntu 13.10 中尝试 ipython --pylab 时

我当前正在使用Ubuntu 13.10,并应用了所有系统更新.我已经安装了Enthought顶篷(版本:1.1.1.1452).而今天,当我试图绘制时,我一无所获.谷歌搜索后,我在命令行中运行了“ipython --pylab",但收到以下消息: Matplotlib backend_wx 和 backend_wxagg 需要 wxPython >=2.8 我可以进入交互式 ipython s ..
发布时间:2021-06-01 20:12:25 其他开发

无法在安装了Canopy的Ubuntu 12.04中升级Matplotlib

我正在尝试升级 Ubuntu 12.04 中的 matplotlib.当我运行命令时: sudo pip install --upgrade matplotlib 我收到此错误: 下载/解压matplotlib为 matplotlib 包运行 setup.py egg_info所需的分发版本 (>=0.6.28) 不可用,并且无法在此脚本运行时安装.请首先安装更新的版本,使用'easy_i ..
发布时间:2021-06-01 19:03:01 其他开发

dateutil 2.5.0是最低要求的版本

我正在Mac OSX(v 10.13.6)上运行jupyter笔记本(Enthought Canopy python发行版2.7).当我尝试导入熊猫(以pd格式导入熊猫)时,我收到以下投诉:ImportError:dateutil 2.5.0是最低要求的版本.我有以下软件包版本: 机盖版本2.1.3.3542(64位) jupyter版本1.0.0-25 pandas版本0.23.1-1 ..
发布时间:2021-02-09 18:51:06 其他开发

错误:线魔术功能

我正在尝试使用python读取文件,但不断出现此错误 ERROR: Line magic function `%user_vars` not found. 我的代码只是非常基本的 names = read_csv('Combined data.csv') names.head() 我尝试读取或打开文件时都会得到此提示.我尝试使用此线程寻求帮助. ​​错误:找不到行魔术函数 ..
发布时间:2021-02-09 18:42:51 其他开发

有思想的顶篷没有运行

我在64位Windows框(Windows 7)上安装了Enthought Canopy. 已成功安装,但Canopy无法从开始菜单运行.我尝试从cmd运行它,但仍然无法运行. 我检查了c:\ Users \ user ...本地和漫游,没有发现错误日志. 我尝试了启用了用户访问控制(UAC)的Windows Vista及更高版本,这是msi安装程序的窍门,但Canopy仍然无法 ..
发布时间:2020-11-29 04:35:13 其他开发

在Win 7上安装32位Canopy,32位计算机失败

我正在尝试在32位Windows计算机上安装Canopy(canopy-1.1.0-win-32.msi).安装似乎可以正常工作,但是当我启动任何工具时,什么都没有发生.我可以打开命令行并运行找到的canopy_cli.exe,它声称我使用了错误的安装程序.我已经做了两次.它是32位的Dell Inspiron.我已经从系统中删除了所有与Python相关的内容,以尝试建立一个干净的基础. 想 ..
发布时间:2020-11-29 04:34:10 其他开发

Matplotlib导入错误ft2font

我在具有Ipython版本2.1.0的64位Mac上的Canopy下安装了Python 2.7.6.这是一个很奇怪的问题,我不确定这是否是路径文件问题.每当我导入matplotlib.pyplot(不仅是matplotlib)时,都会出现以下错误: In [2]: import matplotlib.pyplot as plt -------------------------------- ..
发布时间:2020-11-27 06:27:53 其他开发