tls1.2相关内容

NSURLSession/NSURLConnection HTTP 加载在 iOS 9 上失败

尝试在 iOS9 上运行我现有的应用程序,但在使用 AFURLSessionManager 时失败. __block NSURLSessionDataTask *task = [self.sessionManager dataTaskWithRequest:request completionHandler:^(NSURLResponse * __unused response, id resp ..
发布时间:2021-12-01 17:19:11 移动开发

如何在 ASP.NET 2.0 应用程序中为 API 调用启用 TLS 1.2?

我们的 ASP.NET 2.0 网站通过调用 Authorize.Net 的 API 来处理信用卡交易.Authorize 已通知我们,在某个要宣布的日期,我们的客户必须使用 TLS 1.2 协议进行 API 调用. 微软似乎在这篇 10-22-16 KB 的文章中指出了一个解决方案:https://support.microsoft.com/en-us/help/3154517/suppo ..
发布时间:2021-11-30 18:00:30 C#/.NET

Android 4.1 到 4.4 KitKat - 为 API 启用 TLS 1.2

在尝试禁用 TLS 1.0 时,有 KitKat 设备需要访问我的 API.我尝试覆盖默认套接字工厂但没有成功.我尝试转换为 okhttp.还是行不通.如何让 Android KitKat 连接到我的 API? 解决方案 我在 pre-lollipop 设备上遇到了同样的问题.由于我正在使用 Retrofit,这里是 OkHttp 的解决方案. Tls12SocketFactory. ..
发布时间:2021-11-27 12:41:02 移动开发

Android 预棒棒糖设备出现错误“SSL 握手中止:ssl=0x618d9c18:系统调用期间出现 I/O 错误,连接由对等方重置"

我遇到了一个奇怪的问题,改装一直让我失望 "SSL 握手中止:ssl=0x618d9c18:系统调用期间出现 I/O 错误,对等方重置连接" 在 kitkat 中,而相同的代码在棒棒糖设备中运行良好.我正在使用如下所示的 OkHttpClient 客户端 public OkHttpClient getUnsafeOkHttpClient() {尝试 {最终 TrustManager[ ..
发布时间:2021-11-27 12:37:12 移动开发

是否可以在 .NET 4.0 框架上使用 TLS1.2 发送 HttpWebRequest

我的应用程序连接到 Experian 服务器,Experian 将很快停止支持 TLS 1.0 和 TLS 1.1.所有使用 HTTPS 的连接都必须使用 TLS 1.2 版. 我想对该问题进行一些研究,并查看在 .NET 4.0 框架上使用 TLS 1.2 发送 HttpWebRequest 的工作 如果没有,我可能需要在 .NET 4.5 上创建一个 webservice 并调用它 ..
发布时间:2021-11-26 11:06:21 C#/.NET

是否可以在 .NET 4.0 框架上使用 TLS1.2 发送 HttpWebRequest

我的应用程序连接到 Experian 服务器,Experian 将很快停止支持 TLS 1.0 和 TLS 1.1.所有使用 HTTPS 的连接都必须使用 TLS 1.2 版. 我想对该问题进行一些研究,并查看在 .NET 4.0 框架上使用 TLS 1.2 发送 HttpWebRequest 的工作 如果没有,我可能需要在 .NET 4.5 上创建一个 webservice 并调用它 ..
发布时间:2021-11-26 10:39:59 C#/.NET

.NET Framework 4.0 中的 TLS 1.2

我有一台运行十几个 .NET Framework 4.0 WebForms 应用程序的 Windows Server 2008 R2 服务器,我需要禁用 TLS 1.0 及更低版本.当我这样做时,所有安全连接都失败了,我被迫重新启用 TLS 1.0.有没有办法在framework 4.0环境中使用TLS 1.2?也许我错过了什么? 另外,由于我们使用的CMS版本的限制,我们暂时无法升级Fra ..
发布时间:2021-11-26 10:31:39 C#/.NET

如何在 Java 6 中使用 TLS 1.2

看来Java 6支持TLS到v1.0,有没有办法在Java 6中使用TLS 1.2? 也许 Java 6 的补丁或特定更新会支持它? 解决方案 公共 Oracle Java 6 版本不支持 TLSv1.2.Java 6(后 EOL)的付费版本可能会.(更新 - TLSv1.1 从更新 111 开始可用于 Java 1.6;来源) 联系 Oracle 销售人员. 其他选择是 ..
发布时间:2021-11-25 19:19:46 Java Web开发

是否可以在 .NET 4.0 框架上使用 TLS1.2 发送 HttpWebRequest

我的应用程序连接到 Experian 服务器,Experian 将很快停止支持 TLS 1.0 和 TLS 1.1.所有使用 HTTPS 的连接都必须使用 TLS 1.2 版. 我想对该问题进行一些研究,并查看在 .NET 4.0 框架上使用 TLS 1.2 发送 HttpWebRequest 的工作 如果没有,我可能需要在 .NET 4.5 上创建一个 webservice 并调用它 ..
发布时间:2021-11-24 09:03:57 C#

Powershell - TLS1.2 支持

你知道有没有办法在 powershell 中启用 TLS1.2(即用于 invoke-webrequest 或 invoke-restmethod)? 默认情况下,Powershell 似乎使用 TLS1.0,它与我们所有的网络服务都不兼容. /帕特里克 解决方案 有! [Net.ServicePointManager]::SecurityProtocol = [Net.Se ..
发布时间:2021-11-15 03:23:47 其他开发

带有 TLS 的 Websphere MQ 的 Nifi JMS 输入

我正在尝试使用 JMS 输入创建一个 nifi 流以连接到在 z/OS 上运行的 Websphere MQ.如果队列管理器不受 TLS 保护,我可以使用 JNDI(带有 .bindings 文件)成功连接.当我切换到安全队列管理器时,我收到不受支持的密码套件错误: Caused by: com.ibm.mq.jmqi.JmqiException: CC=2;RC=2393;AMQ9771: SS ..
发布时间:2021-11-12 03:59:22 其他开发

在 Windows Server 2k8(非 R2)上启用 TLS 1.1 和 1.2

是否有人能够在 Windows 2k8 SP2(非 R2)上使用 TLS 1.1 或 TLS 1.2.最近才提供支持 微软支持.我已经安装了更新并做了注册表项,但它似乎没有被启用.有没有办法只查看注册表项就可以检查? 解决方案 您可以使用 https://www.ssllabs.com/ssltest 以测试您的 IIS 配置是否已更新. Chrome 开发者工具下的“安全"选项卡还 ..
发布时间:2021-09-08 20:07:58 其他开发

尽管启用了 Keep-Alive 和会话标识符/票证,但仍进行多次 SSL/TLS 握手

当 Keep-Alive 和 Session Identifiers/Tickets 都处于活动状态时,我很难找出为什么我在同一页面上遇到多次 SSL/TLS 握手(对于同一页面上的多个资源,即多个 HTTP 请求)在网站/服务器上. 我最近在我的网站上激活了 TLS (https),​​因此我想检查这对网站的速度/负载性能有什么影响.通过互联网(例如tools.pingdom.com 和w ..
发布时间:2021-09-08 20:07:55 其他开发

Powershell CRESSSP 和 TLS 1.2

服务器 A 是 Server 2008 R2、Powershell V3 所有 SSL 和 TLS 启用和所有密码.服务器 B 是 Server 2016、Powershell V5 和 Only TLS 1.2 和特定的密码集. 我无法让 Credssp 身份验证从 A 到 B 工作,即使我使用 Net.ServicePointManager]::SecurityProtocol = [ ..
发布时间:2021-09-08 20:07:51 其他开发

托管 Xamarin HttpClient 实现是否支持 TLS 1.2?

应用传输层安全性的官方 Xamarin 文档 (iOS,Android) 声明托管 HttpClient 实现仅支持 TLS 1.0.强烈建议将 Xamarin 应用更新到本机 HttpClient 实现以支持 TLS 1.2.Visual Studio 也说明了这一点: 然而,文档是矛盾的.在描述托管 HttpClient 实现时,它声明如下: 它没有与操作系统完全集成(例如,仅限于 ..
发布时间:2021-09-08 20:07:49 其他开发

在吊销的证书上从 HttpClient 返回更详细的错误消息?

我正在针对执行客户端证书身份验证的 Web 服务器编写代码.我用我的证书链创建了一个 WebRequestHandler,将它传递给一个 HttpClient 对象,然后在 HttpClient 上调用 PostAsync.这适用于未撤销的信任链上的有效证书.当证书被吊销(正如预期的那样)并且 Exception 成员包含此聚合异常时,HttpResponseMessage 任务会出错: 发 ..
发布时间:2021-09-08 20:07:46 其他开发

在所有连接上强制 ServicePointManager.SecurityProtocol 为 TLS 1.2

我有一个发送传出请求的 WCF 服务.目前它使用 SSL 3.0 或 TLS 1.0. 我向其发送请求的服务现在只接受 TLS 1.2. 我可以在请求之前(以及每个请求)设置 SecurityProtocolType,但我希望它对所有传出请求使用 TLS 1.2,而无需指定对于每个请求. 此代码为请求正确设置: 公共函数 SomeService()System.Net.Serv ..
发布时间:2021-09-08 20:07:42 其他开发

在 .NET 4.0 中使用 Web 服务时出现连接错误

我在 .net framework 4.0 中开发了一个 .net web 服务,并部署在 widows server 2008 R2 中.客户可以毫无问题地使用 Web 服务.最近我们将 SSL 证书协议从 SSL 3.0 升级到 TLS 1.2.我的协议升级后,客户无法使用网络服务.我浏览了一些论坛,发现 .net 4.0 不支持 TLS 1.2 协议,所以任何人都可以提出最好的解决方案来克服 ..
发布时间:2021-09-08 20:07:39 其他开发

WCF 服务 TLS 1.2 实施

我们正在尝试在我们的 WCF 服务中强制实施 TLS 1.2. 我们的 WCF 服务托管在我们的 VM Box 上的 IIS 上.我们不确定如何为我们的服务禁用 TLS 1.0 和 TLS 1.1.我们尝试了以下方法: 我们的 WCF 服务(服务器端)和(客户端)中的配置更改** – 对于客户端,我们在主方法中添加了以下代码—— 删除不安全的协议(SSL3、TLS 1.0、TLS ..
发布时间:2021-09-08 20:07:36 其他开发