portable-class-library相关内容

.NET Standard over PCL Xamarin.Forms.Core 项目

我了解到 .NET Standard 现在比 PCL 类库更适合共享代码. 我的问题是,我应该在 PCL 上使用 .NET Standard 库作为 Xamarin Forms 解决方案的核心吗?目前,它将针对 iOS 和 Android,但我们希望未来将 Tizen 用于 TV. 解决方案 .NET Standard 将是未来,所以如果可以,您现在就应该加入. 但要注意.如果 ..
发布时间:2021-11-26 13:16:05 其他开发

将对面向 .NET Standard 2.0 的类库的引用添加到面向 .NET Standard 4.5 的 Xamarin PCL

我正在构建一个 Xamarin 应用程序,并且我在面向 .NET 4.5 框架的 PCL 中有我的共享代码.我还有一个库,它基本上在另一个库中实现了我的 Xamarin 应用程序的服务访问层,该库面向 .NET 标准 2.0. 问题是当我尝试引用后者时,Visual Studio 给了我以下错误: 项目 [服务访问库] 以“.NETStandard,Version=v2.0"为目标.它 ..
发布时间:2021-11-26 13:15:44 C#/.NET

哪个.Net Standard 版本支持哪个Android 版本?

我想将 Xamarin PCL 项目转换为 .Net Standard. 我的问题是,这将支持哪些版本的 Android?我当前的项目支持 Android 4..Net Standard 能支持吗?它是否依赖于 .Net Standard 版本? 我见过这张表但它只是告诉我支持的“Xamarin"版本,我不明白它和 Android 版本之间的联系..Net Standard 是与 An ..
发布时间:2021-11-26 13:15:18 C#/.NET

UWP 中 SQLite 的 PCL 与 .NET Standard 库

我有以下问题. 我在我的 UWP 应用程序中使用便携式库(便携式库与 Xamarin 应用程序共享).这个可移植的库引用了 SQLite.在这个便携式库中,我还使用了 Prism 和 Unity.出于这个原因,我仍然无法将它们升级到 .NET Standard.我使用的 SQLite 库是 SQLite-net-pcl 版本 1.4.18. 在我的 UWP 应用中,我添加了相同的 nu ..
发布时间:2021-11-26 13:13:49 数据库

我应该如何在 VS 2017 RC 中创建面向 .NET Framework 4.5.1 和 .NET Standard 1.3 的库?

这是我第一次尝试不仅仅针对 .NET Framework 的任何内容.我似乎无法从 GUI 中做到这一点.我尝试过项目类型“类库(便携式)"和项目类型“类库(.NET 标准)".我可以将“类库(便携式)"更改为面向 .NET Standard,但随后我无法选择任何其他内容.我不确定是否应该尝试更改“类库(.NET 标准)"的 .csproj 或“类库(便携式)"的 project.json,我只想 ..
发布时间:2021-11-26 13:01:58 C#/.NET

从 Windows 类库引用 .NET Standard 库

我的解决方案中目前有两个项目:一个 Windows 类库(面向 .NET Framework 4.6.1) 和另一个面向 .NET Standard 1.3 的类库.我使用的是 Visual Studio 2015 更新 3. 我从另一个项目中添加了对 .NET Standard 项目的引用,它出现在引用列表中,但是当我想使用它们时,我看不到引用库中的任何类或命名空间(即使引用的库已成功构建 ..
发布时间:2021-11-26 12:55:41 C#/.NET

.Net Core、Portable、Standard、Compact、UWP 和 PCL 之间的区别?

听说过 .Net 核心 .Net 便携版 .Net 标准 .Net 精简版 通用 Windows 平台 便携式类库 所有这些都向我解释为“完整 .Net 的一个子集,允许您面向多个平台".所以我的问题是 有什么不同!? 如果我想编写一个可供尽可能多的受众使用的库,我需要使用其中的哪一个(或多个)? (我的具体情况:我有一个一个库针对.Net 2.0、.Net 4 ..
发布时间:2021-11-26 12:38:29 C#/.NET

在 PCL 中获取程序集版本

我在 .NET 4.5 中有以下代码行,我试图将其构建为可移植类库.其目的是获取程序集版本: this.GetType().Assembly.GetName().Version.Major; 问题是 Assembly.GetName() 在 PCL 中不可用.有没有办法在 PCL 中获取汇编版本? 我知道可以解析 Assembly.FullName,但我想要一个更好的解决方案. 解 ..
发布时间:2021-11-26 12:05:24 其他开发

MVC 4/Razor 中的可移植类库与 Visual Studio 2012 RC?

自从使用 Visual Studio 2012 RC 以来,我们在剃刀视图中使用便携式类库(.net 4.5 和 Metro 配置文件)中的类时会收到 HttpCompileException. 例外:(德语到英语在谷歌上翻译,抱歉) System.Web.HttpCompileException (0x80004005):c:\Users\user\AppData\Local\Temp\ ..
发布时间:2021-11-26 11:28:32 C#/.NET

将对面向 .NET Standard 2.0 的类库的引用添加到面向 .NET Standard 4.5 的 Xamarin PCL

我正在构建一个 Xamarin 应用程序,并且我在面向 .NET 4.5 框架的 PCL 中有我的共享代码.我还有一个库,它基本上在另一个库中实现了我的 Xamarin 应用程序的服务访问层,该库面向 .NET 标准 2.0. 问题是当我尝试引用后者时,Visual Studio 给了我以下错误: 项目 [服务访问库] 以“.NETStandard,Version=v2.0"为目标.它 ..
发布时间:2021-11-24 21:05:10 C#

.NET Standard over PCL Xamarin.Forms.Core 项目

我了解到 .NET Standard 现在比 PCL 类库更适合共享代码. 我的问题是,我应该在 PCL 上使用 .NET Standard 库作为 Xamarin Forms 解决方案的核心吗?目前,它将针对 iOS 和 Android,但我们希望未来将 Tizen 用于 TV. 解决方案 .NET Standard 将是未来,所以如果可以,您现在就应该加入. 但要注意.如果 ..
发布时间:2021-11-24 21:05:04 C#

哪个.Net Standard 版本支持哪个Android 版本?

我想将 Xamarin PCL 项目转换为 .Net Standard. 我的问题是,这将支持哪些版本的 Android?我当前的项目支持 Android 4..Net Standard 能支持吗?它是否依赖于 .Net Standard 版本? 我见过这张表但它只是告诉我支持的“Xamarin"版本,我不明白它和 Android 版本之间的联系..Net Standard 是与 An ..
发布时间:2021-11-24 21:04:14 C#

UWP 中 SQLite 的 PCL 与 .NET Standard 库

我有以下问题. 我在我的 UWP 应用程序中使用便携式库(便携式库与 Xamarin 应用程序共享).这个可移植的库引用了 SQLite.在这个便携式库中,我还使用了 Prism 和 Unity.出于这个原因,我仍然无法将它们升级到 .NET Standard.我使用的 SQLite 库是 SQLite-net-pcl 版本 1.4.18. 在我的 UWP 应用中,我添加了相同的 nu ..
发布时间:2021-11-24 21:02:47 C#

我应该如何在 VS 2017 RC 中创建面向 .NET Framework 4.5.1 和 .NET Standard 1.3 的库?

这是我第一次尝试不仅仅针对 .NET Framework 的任何内容.我似乎无法从 GUI 中做到这一点.我尝试过项目类型“类库(便携式)"和项目类型“类库(.NET 标准)".我可以将“类库(便携式)"更改为面向 .NET Standard,但随后我无法选择任何其他内容.我不确定是否应该尝试更改“类库(.NET 标准)"的 .csproj 或“类库(便携式)"的 project.json,我只想 ..
发布时间:2021-11-24 20:51:20 C#

从 Windows 类库引用 .NET Standard 库

我的解决方案中目前有两个项目:一个 Windows 类库(面向 .NET Framework 4.6.1) 和另一个面向 .NET Standard 1.3 的类库.我使用的是 Visual Studio 2015 更新 3. 我从另一个项目中添加了对 .NET Standard 项目的引用,它出现在引用列表中,但是当我想使用它们时,我看不到引用库中的任何类或命名空间(即使引用的库已成功构建 ..
发布时间:2021-11-24 20:44:39 C#

为什么我的 PCL 不能使用 System.Runtime?

我有一个针对以下平台的 PCL: .NET 框架 4.5 Windows 8 Windows Phone 8.1 我需要添加对 System.Runtime 因为我想使用另一个依赖它的包.据我所知,version 4.0.0 似乎包含目标上面提到的平台.但是,当我尝试通过 NuGet 安装它时,我得到了这个堆栈跟踪: PM>安装包 System.Runtime -Version ..
发布时间:2021-11-24 17:25:24 C#

.NET Core 和 .Net 4.5.2 使用的通用类库

我对 .Net Core 还很陌生,但已经创建了一个可用的 Asp.Net Core WebAPI 站点 - 现在我想与另一个项目共享一些代码... 我安装了带有 Update 3 的 Visual Studio 2015. 我从这里安装了 DotNetCore.1.0.0-VS2015Tools.Preview2.exe. 我想创建一个可供其他两个库使用的共享库 (PCL) - 它 ..
发布时间:2021-11-24 15:30:58 C#

在 Visual Studio 代码中创建类库

这可能是一个愚蠢的问题,假设我没有 Windows 操作系统,有一个 Linux.我创建了一个 .Net 核心控制台应用程序,还想创建一个类库并在控制台应用程序中引用它.我无法找到我是否能够做到,也无法在 Microsoft .Net 核心页面上找到示例.vs代码中有扩展吗?或者它不可能吗?如果我弄错了,你能指导我吗? 解决方案 最好的方法是从控制台执行此操作,因为您正在使用最新支持的模板 ..
发布时间:2021-11-24 13:35:57 C#

.Net Core、Portable、Standard、Compact、UWP 和 PCL 之间的区别?

听说过 .Net 核心 .Net 便携版 .Net 标准 .Net 精简版 通用 Windows 平台 便携式类库 所有这些都向我解释为“完整 .Net 的一个子集,允许您面向多个平台".所以我的问题是 有什么不同!? 如果我想编写一个可供尽可能多的受众使用的库,我需要使用其中的哪一个(或多个)? (我的具体情况:我有一个一个库针对.Net 2.0、.Net 4 ..
发布时间:2021-11-24 12:23:39 C#

在 PCL 中获取程序集版本

我在 .NET 4.5 中有以下代码行,我试图将其构建为可移植类库.其目的是获取程序集版本: this.GetType().Assembly.GetName().Version.Major; 问题是 Assembly.GetName() 在 PCL 中不可用.有没有办法在 PCL 中获取汇编版本? 我知道可以解析 Assembly.FullName,但我想要一个更好的解决方案. 解 ..
发布时间:2021-11-24 11:24:23 C#