rubygems相关内容

在 32 位或 64 位 Linux 操作系统服务器中使用 Nginx+mysql 运行 Ruby on Rails + Phusion 乘客及其性能?

我有 Java 背景,并且是 Ruby on Rails 的新手,对于为我的服务器选择 32 位还是 64 位 Linux 操作系统有很多困惑. 这是我所知道的,如果我错了,请纠正我: 32 位操作系统不能使用超过 4GB 的 RAM,但通过 pae 是可能的.通过这种方式,即使没有单个常规应用程序可以同时访问所有额外的内存,它也是有用的.所以我打算使用 64 位 Linux 操作系统 ..
发布时间:2021-11-25 00:22:40 C#

MySQL 安装:错误:无法构建 gem 本机扩展

我正在尝试将 MySQL 安装到最新版本,因为安装过程中的某个地方出现了错误.我运行命令 gem install mysql 并收到以下信息: 构建原生扩展.这个可能需要一段时间......错误:错误安装 mysql: 错误: 失败构建 gem 本机扩展. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ru ..
发布时间:2021-11-20 22:23:39 MySQL

Ruby gem mysql2 安装失败

当我尝试安装 mysql2 gem 时,它失败且没有明显错误.有谁知道如何解决这个问题,以便安装 mysql2? $ sudo gem install mysql2构建本机扩展.这可能需要一段时间...错误:安装mysql2时出错:错误:无法构建 gem 本机扩展./System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/rub ..
发布时间:2021-11-20 22:07:53 MySQL

gem install: 无法构建 gem 本机扩展(找不到头文件)

我使用的是 Fedora 14,并且安装并运行了 MySQL 和 MySQL 服务器 5.1.42.现在我尝试以 root 用户身份执行此操作: gem 安装 mysql 但我收到此错误: 构建原生扩展.这可能需要一段时间...错误:安装mysql时出错:错误:无法构建 gem 本机扩展./usr/bin/ruby extconf.rbmkmf.rb 在/usr/lib/ruby/ruby. ..
发布时间:2021-11-20 21:50:24 MySQL

安装 mysql2 时出错:无法构建 gem 本机扩展

我在尝试为 Rails 安装 mysql2 gem 时遇到一些问题.当我尝试通过运行 bundle install 或 gem install mysql2 来安装它时,它给了我以下错误: 安装 mysql2 时出错:错误:无法构建 gem 本机扩展. 如何解决这个问题并成功安装mysql2? 解决方案 在 Ubuntu/Debian 和其他使用 aptitude 的发行版上: ..
发布时间:2021-11-20 21:12:59 MySQL

gem 安装:错误:无法构建 gem 本机扩展

我正在使用 Arch Linux 并安装了 Ruby(这是 2.0.0 版). 当我安装 Ruby 时,它说我应该添加: $(ruby -rubygems -e "puts Gem.user_dir")/bin 到我的路径,我将它添加到 .bashrc 当我尝试 gem install rails 或任何其他 gem 时,它给出错误:无法构建 gem 本机扩展.这是完整的错误: ..
发布时间:2021-11-17 03:25:29 其他开发

M1 MBP Rails db:create 为 msgpack 抛出错误

嗨,我是 Ruby on Rails 的新手.当我运行 rails db:create 时,在 M1 MBP 上运行时出现以下错误: /Library/Ruby/Gems/2.6.0/gems/msgpack-1.4.2/lib/msgpack.rb:8:in `require':dlopen(/Library/Ruby/Gems/2.6.0/gems/msgpack-1.4.2/lib/msg ..
发布时间:2021-11-16 20:34:41 其他开发

使用 selenium 和 Appium 是否可以在 wifi 网络之间切换?

使用:selenium webdriver、rubygems、appium、android 和 ios 设备 我正在测试的应用程序有一个按钮,只有在连接到特定无线网络时才会启用该按钮.我想创建一个脚本来检查按钮是否处于活动状态 vKioskStatus = element.enabled?看跌期权(vKioskStatus) 如果它不活动,那么我想更改 wifi 网络.是否可以在移动设 ..
发布时间:2021-11-16 20:10:27 其他开发

如何找到安装 Ruby Gem 的路径(即 Gem.lib_path c.f. Gem.bin_path)

Gem.bin_path('cucumber', 'cucumber') 将返回二进制/可执行文件的路径.似乎没有这样的函数来返回库路径.在这种情况下,理想情况下会返回: /home/hedge/.rvm/gems/ruby-1.9.2-p136@bbb-bdd-meta-bdd/gems/cucumber-0.10.0/lib 我是否遗漏了什么,或者是否有一种简单/一种方法可以获取此信息? ..
发布时间:2021-11-15 01:02:22 其他开发

Web 应用程序无法启动乘客错误 (Apache2) - 引用不存在的 Ruby 补丁

使用最新版本的 RVM 从 p247 更新到 Ruby 2.0.0 (P353) 的最新补丁后,我遇到了问题.这是我的原始问题的链接,我遇到了旧补丁的 RVN 环境文件丢失的问题,该补丁不再存在于我的系统中.RVM 已更正,该问题消失了. 错误:之后缺少 RVM 环境文件做rvm升级命令-Passenger 4.0.23 我继续使用我的Passenger Enterprise 帐户中的 ..
发布时间:2021-11-11 22:15:05 其他开发

使用 Ansible 安装 Bundler gem

我正在尝试使用 Ansible 在我的 VPS 上安装 Bundler. 我已经设置了 rbenv,全局 ruby​​ 是 2.1.0. 如果我以 root 身份通过 SSH 进入服务器并运行 gem install bundler,它会完美安装. 我尝试了以下三种使用 Ansible 安装 Bundler gem 的方法,所有三种方法都没有产生错误,但是当我通过 SSH 进入并 ..
发布时间:2021-11-11 01:01:10 其他开发

使用 Ansible 安装 Bundler gem

我正在尝试使用 Ansible 在我的 VPS 上安装 Bundler. 我已经设置了 rbenv,全局 ruby​​ 是 2.1.0. 如果我以 root 身份通过 SSH 进入服务器并运行 gem install bundler,它会完美安装. 我尝试了以下三种使用 Ansible 安装 Bundler gem 的方法,所有三种方法都没有产生错误,但是当我通过 SSH 进入并 ..
发布时间:2021-11-10 23:51:43 其他开发

如何安装 CocoaPods?

我参考了很多链接并尝试过,但没有成功.阅读CocoaPods文档,多次尝试安装,但总是因为启动步骤失败.我发现了一个错误,我无法先安装 gems.一步一步是什么步骤?如安装步骤或演示. 这是我尝试过的一个链接. 屏幕截图指的是我收到的这个控制台错误: 解决方案 POD 安装 打开终端并输入: sudo gem install cocoapods Gem 将安装在系统库 ..
发布时间:2021-09-30 19:07:24 其他开发

如何修复 WSL 上 Ruby Gems 安装程序的错误?

我尝试使用 RubyGems 安装软件包(请注意,我使用的是适用于 Linux 的 Windows 子系统).我要安装 Jekyll 包. 我输入了 $ gem install jekyll.之后,它想出了一个错误: 构建原生扩展.这可能需要一段时间.../usr/lib/ruby/2.5.0/rubygems/ext/builder.rb:76: 警告:PATH 中不安全的世界可写目录/ ..
发布时间:2021-09-27 18:47:16 其他开发

在 Windows 10 上的导轨上安装 ruby​​ 时出错

我想按照此视频的相同说明在 Windows 10 的导轨上安装 ruby​​:https://www.youtube.com/watch?v=G-B_KUFNkQQ 当它完成 ruby​​ 的安装时,我返回到控制台并且在 gem install rails 之后,我得到这个错误: C:\Users\Usuario>gem install rails --no-document暂时增强 MS ..
发布时间:2021-09-25 19:57:03 其他开发

ruby-debug-ide 命令显示在我的脸上

所以我正在努力对旧应用程序进行一些甜蜜的远程调试操作,并通过 https://github.com/ruby-debug/ruby-debug-ide 让我的 ruby​​mine 运行起来.在我的 Gemfile 中安装这两个 gem... gem 'ruby-debug-base19x', '~>0.11.32'gem 'ruby-debug-ide' gems 安装正常 但是当我加 ..
发布时间:2021-07-12 18:31:18 其他开发

'pathutil' ruby​​ gem 与 jekyll (v3.9.0) 和 ruby​​ (v3.0.0) 兼容吗?

我的问题:我有一个基于 jekyll 的静态网站;运行 bundle exec jekyll serve (按照 jekyll 文档的指示)后,我得到了下面的堆栈跟踪.我在堆栈跟踪中为该博客文章文件创建的 Markdown 文件完全是标准语法.我已经在 google 上搜索了特定的错误,并获得了有关无法解决我的问题的类似错误的帖子.我还搜索了 jekyll 文档,看看是否有任何不兼容的问题. ..
发布时间:2021-07-12 18:31:01 其他开发

M1 MBP Rails db:create 为 msgpack 抛出错误

嗨,我是 Ruby on Rails 的新手.当我运行 rails db:create 时,在 M1 MBP 上运行时出现以下错误: /Library/Ruby/Gems/2.6.0/gems/msgpack-1.4.2/lib/msgpack.rb:8:in `require':dlopen(/Library/Ruby/Gems/2.6.0/gems/msgpack-1.4.2/lib/msg ..
发布时间:2021-07-12 18:30:58 其他开发